Frictional Games Forum (read-only)

Full Version: Problems Launching Black Plague Demo
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've downloaded and installed the Black Plague Demo and was thrilled to play it; but, when I tried to open it all I get is;

"The procedure entry point alSource3i could not be located in the dynamic link library OpenAL32.dll."

I've tried re-installing the game with and without open AL and I've installed the updated open AL as well. I tried removing the .dll from the game folder and I still get the same results; heck, I've even tried it with older versions of the .dll and still get the same results.
I'm going to try updating my sound card drivers (Realtek HD codec), although I'm fairly sure that won't help, please can some one help me!?
Checkout this thread:

To summarize, it looks like the solution is to delete the OpenAL32.dll and wrap_oal.dll files from the game's folder.
First of all, uninstall OpenAL in the control panel. Then make sure no OpenAL32.dll or wrap_oal.dll is in your Windows/System32 folder. If you find any, delete them. Also, there can't be any of these files in your game redist folder.
Then, install the updated OpenAL redistributable, and make sure you can find the proper files in Windows/System32. That is,
- OpenAL32.dll, version 6.14.357.22
- wrap_oal.dll, version
If you wanna make extra sure these are being used, copy them to the game redist folder, overwriting the previous ones in case they are there.

Don't use older files, as they won't include alSource3i for sure. There are some versions that do, but I'm not sure which ones they are, so best to use the latest.
It worked! Thanks a lot. I appreciate the help.