Frictional Games Forum (read-only)

Full Version: Requiem crashes on new game
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Running on Ubuntu 8.10 32-bit, nvidia 6100 with proprietary driver 180.11, locale pl_PL.UTF-8.

Black Plague installed from, Requiem installed from into ~/PenumbraBlackPlague

Black Plague runs correctly (barring the problem described in this thread - now solved, or at least worked around).

Requiem crashes on starting a new game. hpl.log attached.

Also, after pressing "New Game" in the main menu, no new message appears, just Yes and No. The crash happens after clicking on Yes.

EDIT: Attached wrong log file.
I'm not 100% sure on Linux paths, are you sure it is only "~/PenumbraBlackPlague" and not supposed to be "~/PenumbraBlackPlague/redist"?

If things are installed correctly the main requiem folder should be in the redist folder for black plague and be called expansion01.

The other odd thing is that in the log file it tries to load the first level from Overture and not the first level from Requiem. Have you edited the settings file for requiem in some way so that maybe by mistake you entered some incorrect information? Or perhaps name the file wrong or anything like that? Perhaps when you fixed the 1024*768 resolution you mentioned in the other thread something else got changed, I would suggest uninstalling it all and making sure you remove the setting files and then retry.
Thank you for your answer, jens.

The Requiem installer detects where Black Plague is installed automatically and I'm not one to argue with it. It is /home/USERNAME/PenumbraBlackPlague.

The PenumbraBlackPlague folder does not contain a redist folder. It contains the expansion01 folder, and Requiem binaries as well.

Since I cannot start Requiem (or BP) at all without creating the settings.cfg file manually, I did just what I described in the other topic: I create the file in the correct folder and put in the width/height line (and ONLY that line). All the other entries are generated automatically by Requiem when I exit normally.

settings.cfg attached (as settings.cfg.txt, because trying to attach the settings.cfg file results in an error that the file type is not allowed, for some reason). Please note that the <Screen> line being first undoubtedly has to do with me having inserted it manually (but the FullScreen and Vsync entries were created by Penumbra, not me).

Looking at settings.cfg it indeed does mention level00_01_boat_cabin.dae. The problem is, I did not put it there. I don't even have Overture installed.
The settings file is strange as it seems to be a mix between Overture and Black Plague settings.

To create the settings file manually, go into expansion01/config and make a copy of the settings_default.cfg file, rename it settings.cfg and place it in the folder you created previously and edit width/height as before. Start the game and see if it works, if done correctly the game should !not! try to load level00_01_boat_cabin.dae.
Requiem now starts correctly. Thank you.

I did not know there was a default settings file in the installation directory. I will amend my last post in the "out of range signal" thread appropriately.