Frictional Games Forum (read-only)

Full Version: EXCEPTION_ACCESS_VIOLATION 0023:01221D16
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
Can you please post the hpl log again after having updated to 1.7.8?

(12-09-2014, 06:39 PM)Haeusse Wrote: [ -> ]My graphics card is GeForce 9600 GT/PCIe/SSE2 and the driver is currently updated.
I also updated DevIl to version 1.7.8, but Amnesia still crashes while starting.

also have you had the game working before? did you check the list of programs that can interfere with the game and made sure those are not active?
Here is the hpl.log again. The program has never worked before.
There are no interference programs from the list.

We have an gateprotect firewall, but the ports necessary for steam are opened.
I *think* I solved this while trying to get to sleep last night Smile

The new amnesia is built with a later version of visual studio, which needs dll files that can not be bundled within the game folder. Can you please download the following files and install them and see if this fixes it? (if so this will be bundled with the game and auto-installed in the system. It actually does this already for standalone version, but not on Steam.)

http://pub.thedarkswarm.com/temp/vcredist_x86.exe <-Take this first, install and try the game. If not working then also take this -> http://pub.thedarkswarm.com/temp/vcredist_x64.exe and install and try the game.
Sorry, but it is not the solution.
I tried both packages, but they seemed to be already installed.
The error stays the same.
But I have VS 2008 on my machine. Can this be a problem?
No should not be. Hmm, to be sure if you browse the local files of Amnesia (right-click on game in steam, properties, last tab), temporary move the msvcr71.dll and msvcp71.dll out of the folder in case they cause a conflict and then try to run the game again.

If not working..

Try turning off steam overlay for the game (in properties in steam) and also try starting the game or launcher directly from the folder by running launcher.exe and amnesia.exe.
The removal of the dlls and the start direcly from the folder do also not work.
OK last thing. Check the NVIDIA control panel and make sure settings are set to application controlled (probably is a set default option you can use).

If not that either then out of ideas and will have to ask a programer to make a amnesia.exe with extended debug info. Sorry for not having a simple and direct solution!
Every possible setting in Nvidia control panel is on application controlled.

Maybe we try a debugging version, that is ok.

If this has no success, is it possible to download and install the previous version 1.2?
Im not sure why its crashing. I have created a .pdb file that should give a more detailed information about the crash

Try this:
- Download https://dl.dropboxusercontent.com/u/2378...aDebug.zip
- Unzip in the same folder as Amnesia.exe
- Run Amnesia.exe and let it crash
- Upload the errorlog to the forum

The new errorlog should contain some more information about where the crash happened
Here is the error.log after putting the pdb file in the Amnesia folder.
Pages: 1 2 3 4