Frictional Games Forum (read-only)

Full Version: Mac Launching Problems (check patch above)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Final patch available at:

OK, here's what I've found out about the launching issues.

I downloaded the penumbracollection-1.0.dmg from the same place all of you have been getting it, and ran it on my Macbook pro (ATI video card). which is *NOT* my primary development system (just to be sure my existing environment wouldn't screw things up)

And, guess what, I ran into the same issue.
The apps wouldn't run, or would sometimes run, but then fail the next time.

If i moved all the apps to another dir and back again, it would work for one run.
Very strange.

I moved them all out of the way and copied over my pristine copies from the other system (where I made the DMG out of to begin with). Those worked.. They actually launched from the collection launcher as well.

I did comparisons of those and the ones from the DMG... NO DIFFERENCE!!!!!

hmm... Blew out my Launch Services Cache (you can google for that one)
no difference.
So, I threw away the whole installed directory and restarted the system.

Re-installed from the DMG, and everything worked fine out of the box w/o any mucking around

Now, what I *THINK* is going on here is some weird issue with the Launch Services in OS X and the "quarentine" flag that OS X puts on files.. (You know that dialog that says "hey you downloaded this from the internet, are you SURE you want to run it?")

So, first I'd suggest restarting your system to see if that fixes the issue.

If it doesn't follow this page.

and see if it fixes it.

If it STILL doesn't, follow that page again and "delete" the installed Penumbra Collection folder.

Reboot.... Reinstall.. and see if it works.

And Please report back on this thread what did work.
I was able to finally get this working after I removed the two files in the Macintosh HD > Library > Caches folder:

And this is where the directions listed on the other site were a little off, I had to remove the file under Macintosh HD > Library > LaunchDaemons folder:

Then restarted and it all started working.
Ok, I was able to open Overture once, and now I can open Requiem. Requiem now always brings up the warning that I downloaded the program, and Overture will not launch.
Okay, I also tried the suggestions above. Firstly I tried resetting the computer and overture would still not load. (no trouble loading black plague or requiem though).

Secondly, as also suggested by urkle, I followed the instructions at
The game loaded!! However, there is a catch. I exited the game and tried to load the game again and got the same message again that "you cannot open application because it may be damaged or incomplete". I tried resetting computer again, but this did nothing. Following the steps in the link only works for the first time I launch the game after reset. It appears that I need to follow the steps again from the link above and reset the computer to get the game game to load again. Hopefully there is a more permanent solution to the problem. I don't fancy having to delete files and reset my computer every time I want to launch this game.

I am running the game on a MacBook Pro 2.4ghz Core 2 Duo, 2gb DDR3 ram, Geforce 9600M GT using OS 10.5.7.
Oh yeah, I also tried removing the game folder and reinstalling as also suggested, to no avail.
Yeah, I have to reinstall the game every time I want to play. Kind of lame. Hope you guys figure this out.

PS. I don't have to reboot, just reinstall, which takes like 10 minutes >_<

Edit: I see some people are having success moving back and forth. I'll try that next time.
It works now! I follwed all the steps in the link above. I also deleted the game folder and files and reinstalled once i rebooted. It seems the game loads everytime ONLY when i click on the penumbra application file within the penumbra/overture folder. As long as I launch from the overture folder the game works every time now!!!
Does anyone have a nice hard wall for me to back my head into???

Opened up the laptop this morning, and it stopped working.

There is some kind of corruption going on in OS X's Launch Services, as when I dump the launch services DB is registered fine, BUT I try launching and the dump shows there's no executable (hence the errors everyone is getting).

So it seems if you Don't use the Launcher, and Don't use the shortcuts/aliases it'll work ok. But WHY I have no clue. but I am working on it.
Well, I got somewhere, but at the same time nowhere. My other Mac does not exhibit these issues at all in any way, shape, or form. they are both running 10.5.7, and both were "upgraded" from 10.4.x. Really strange things going on here.

However, I do believe Ryan "Icculus" Gordon put it right in his .plan entry a few years ago.

As if I run his small app, it fixes the launch services cache for a runSmile

this is how I worked around the problem (using unix-foo)

1. make a tar archive of Applications/Penumbra\ Collection/
2. move it to a linux box
3. on linux, use find and rm to delete all files starting with ._ (the "quarantine ACL" thing)
4. tar it again
5. move it back to the mac and untar it (replacing the original)

So the problem appears definitly be connected to the Mac's "quarantine ACL" thingies...

Someone with deeper knowledge of the Mac could certainly come up with a
way (script?) to remove those directly on the Mac...

I just bought the Penumbra Collection, and I'm seeing the same problem on my MacBook: Overture won't launch, Finder reports that the executable might be damaged, using open from the CLI reports error -10827.

Chris> the quarantine flag is stored as an extended attribute and is not part of the ACL. You could remove it on a Mac using the xattr command; however, that flag is a red herring. Launch Services reports that the application is broken before even checking the quarantine flag, and if you force it to re-register the application, it shows the quarantine check dialog, after which it runs. I think copying the application to Linux worked for you because when you copied it back Launch Services detected it as a new application and registered it anew.

Urkle> Icculus was referring to problems that can occur when you're developing an application and Launch Services has cached information from an older build of your app, and fails to notice later changes you make. However, that's limited to one's development machine, and should never affect end users. Also, forcing Launch Services to update its cache would fix those problems permanently (unless you change the Info.plist and the cache becomes updated again, but that's not the case here).
I think there is some other problem with Penumbra that causes LS to detect the application as broken.

BTW, there is a built-in tool for working with the LS database, though it's well hidden. You can force LS to reregister Penumbra by running:
LaunchServices.framework/Versions/A/Support/lsregister -v -f /Applications/Penumbra\ Collection/Overture/
(Put it all on one line; I had to break it since it was breaking the post's width in preview. Needs some CSS with overflowConfusedcroll on code blocks.)

Edit: one oddity I noticed is that the disk image contains a file called "". I think that's used to make Time Machine recognize the volume as a backup target. This might be another red herring, but Launch Services refuses to directly launch applications from Time Machine backups (otherwise it would create a huge mess with twenty registered copies of the same app); although this should only apply to the backupsdb folder, and not the entire volume, it's still worth investigating. Was the disk image built from a TM backup?
At any rate, removing "" from the disk image would be a good idea.
I am familiar with what Icculus was referring to, however his little app is SOO much easier to use than lsregister (which I was using before, and was using to dump the contents of the cache).

Now, as for this time machine file.. That's strange that it ended up in the DMG. The machine I created the install on has time machine disabled, BUT the "laptop" which is running into the issue does have time machine enabled. So I wonder....

Now, I even went as far as doing a completely Clean build of Overture and running it on the laptop... Same issue. this is getting very weird.

Oh, and I've already removed the quarentine xattr and it didn't fix anything at all Sad

It's also strange that Overture seems to "break" more than BP or Requiem.. and they are nearly identical code bases. Now there could be some issues with the launcher.. I'm going to revisit the launcher code and see if I can find anything in there.

Anyways.. Thanks everyone for all your troubleshooting and patience with this one.
Pages: 1 2