Frictional Games Forum (read-only)

Full Version: it's walking by itself
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
i just purchased the 3 games today on linux. during the games overture and black plague (have not tried the 3rd yet), it decided to start walking by itself without touching the keyboard or mouse.

in overture it kept moving in the left direction and i think maybe backwards in black plague. it happened relatively early into each game, although i have not played to far into either game.

while this was happening in overture, i could move forwards and backwards with the keyboard while it was also going left, but pressing right would not counteract the movement. movement with the mouse still worked fine while it was happening.

i know its not a problem with the keyboard because i don't experience any key sticking problems on the computer. i do not have any controllers or joysticks plugged into this machine. i am playing with an optical ps/2 mouse and ps/2 keyboard.

eventually after a couple of minutes i was able to get it to stop. in black plague it stopped moving by itself after pressing jump. in overture it stopped when i walked over the hatch that is seriously solid that wont be opened by hand which i think that is the same room where it had started moving itself. jumping did not stop it from moving in overture, but i dont know that in black plague it was definitely from jumping or just from moving to a certain spot.

this has only happened 2 times so far (once during each game). i am going to keep playing the first one for now and see if i can get it to happen again.

i am running kubuntu 9.04 x86_64 with core2quad 2.83g and dual radeon hd4550 in crossfirex mode. other than that so far the games have been great to play and everything else has been working fine.
while walking around i was holding down forward and then held down left simultaneously to navigate through a door and when i released the keys it kept walking forward by itself. after about 10 seconds of hitting keys i held down both forward and left and let go and it stopped moving by itself. i tried to repeat this again at the same spot, but could not get it to happen again.
again.. after putting the metal bar in that device it just started walking forward by itself until i waled over the hatch. then when i pulled the bar to spin the mechanism to open the hatch it started to walk forward again by itself and down to the next level it continued moving by itself until i reached a wall and hit the right mouse and some text came up and then when i clicked it to go away it stopped moving by itself..
its happened a bunch more times and seems random and i start hitting a bunch of keys and the mouse buttons and it will stop
that is VERY VERY strange.. I'd suggest moving libSDL out of the "./lib" directory in the game install so it'll use your system libSDL to see if that fixes anything.
i just tried moving out libSDL* from ~/PenumbraCollection/Overture/lib/ and within a couple of minutes it started walking forward by itself...

that reminds me i should report another problem i am having when exiting the game, open windows on my 12 virtual desktops will automatically get resized to the full height of the desktop. i can resize the height smaller then start the game and when exiting they are again full height of the screen. moving out those libs didnt help this problem either.. i will start a new thread on this one.