Frictional Games Forum (read-only)

Full Version: Having a teeny bit of a problem compiling...
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I decided to give Penumbra: Overture a try, and would you imagine? I get an error message on the first thing I try to build Smile Oh, and not just ONE error message, I got the whole shebang (fail1.png is the majority of it, fail2.png being the rest)

Fail1

Fail2


I hope it's of use && you can help me Cool Big Grin
Did you checkout the OALWrapper code as well as the HPL1 engine code?

the hpl1engine CMAke file references "../OALWrapper" to find the OAL wrapper code project and includes.. so you MUST make sure they are in the same parent directory. (as well as the extracting of the dependencies ZIP)
I hadn't thought of that, actually. I figured that since I got the OALWrapper directory out of another of my directories (/root/Downloads/Penumbra/ to be exact) and assumed it might have corrupted while moving it. I redownloaded it and it seemed to fix the problem. I thank ye kindly Cool
I spoke too soon, it stopped 'make' at around 75% done and came up with this error message:

Code:
make[2]: *** [CMakeFiles/HPL.dir/sources/impl/GLee.c.o] Error 1
make[1] *** [CMakeFiles/HPL.dir/all] Error 2
make: *** [all] Error 2
bash-3.1#

I'm having all sorts of bad luck today, aren't I?
Did it have any more information then that? try running

Code:
make VERBOSE=1
Yes, it did, I just can't C+P from rxvt. I had to type it in manually. Here is a pic of the rxvt after I run 'make VERBOSE=1'. My rxvt can't store all of what it put out, so I can only give you a portion of it.
(06-15-2010, 04:25 PM)steviebob Wrote: [ -> ]Here is a pic of the rxvt after I run 'make VERBOSE=1'.

I ran into the same thing a couple days ago during my first go at building Overture. I found that the file "dependencies/include/GL/GLee.h" was incomplete. I replaced it with the GLee.h straight from the source: www.opengl.org/sdk/libs/GLee/ (downloads at bottom), making sure to do this in HPL1Engine/include/GL/ as well. After that, I had a working build.

At first, I wasn't sure if the included GLee.h was the problem or something on my end (been having problems with this disk/partition recently), so I didn't report this. Your problem confirms it, though.
the issue is I "upgraded" GLee in the HPL1Engine core and put the GLee.h header in the HPL1Engine source. So I guess the include paths are screwed up and it's pulling in the one from the dependencies instead..

Also, steviebob, you don't CTRL-C to copy out of a RXVT, you simply "select" the text and then in your text editor (or directly in Firefox or Chrome in the text area field) press the middle mouse button, and whatever text is "selected" in another application will magically appear.. (The X-Selection clipboard.. an AWESOME thing)
Well then, it would have helped if I knew about the x clipboard earlier Smile
As you two said, I downloaded the source, moved GLee.h to ../HPL1Engine/include/GL/, ran 'make' and it worked beautifully. I successfully compiled Penumbra: Overture. Man, you two are life savers! Oh, and thanks for the tip about rxvt, I'm glad I know that now. It will help SO much when I want to report a problem or something along those lines Smile

EDIT:
Heh, this is kind of embarrassing... It compiled fine, now just how do I play it? ._.'
I tried running overture.bin, but it the screen just flashes black one time and nothing else. Hm.
(06-17-2010, 02:21 AM)steviebob Wrote: [ -> ]It compiled fine, now just how do I play it?

You need to put the binary in the install directory of the actual game (the one with resources.cfg). What I've done is simply link my compiled binary into this dir. It stays current that way. In this dir, there is a script called "penumbra" that launches the binary. I modified it to call my (linked) "overture.bin" rather than "penumbra.bin", so that way I can launch my modified copy as if I were launching the game proper.

Note: I have the full Penumbra collection installed. If you just have Overture, the filenames might be different. (I dunno-- I had only played the standalone Overture for about 20-30 minutes after buying THIB before I forked over the extra $5 for the other games-- I was that impressed!) The idea will be the same, though. I think the other option is to just copy all the game data into your build directory, but that's messier imo.
That's a toughie, seeing as how I don't know what you mean by "where it's actually been installed". I just compiled it and it gave me all of these files in the PenumbraOverture directory, with resources.cfg nowhere in site, but there IS a resource.h file, if that helps. haha.
Pages: 1 2