Frictional Games Forum (read-only)

Full Version: Error code 0xc0000007b at game launch
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I've installed Amnesia: A Machine For Pigs today and I ran into a problem. As soon as it installed, I clicked on the icon and the game won't start at all. I got this error code 0xc0000007b and I've looked everywhere for a solution and nothing seems to work. I had played this game before on my laptop when I had Windows 7, and it worked just fine, but ever since I updated to Windows 10, this error code keeps showing up. Any solutions?
Try to post the log file from Documents\Amnesia\Pig\hpl.log
Try running it in compatibility mode for windows 7, otherwise....

Please refer here before anything.

If that doesn't work try troubleshooting your graphics card here.

If all else fails post your hpl.log into this thread. Do not make a new one.
(07-15-2016, 02:51 AM)7heDubz Wrote: [ -> ]Please refer here before anything.

If you updated to Windows 10, your problem may be just the DPI settings.
From that link above, look at Problem A, number 7 to find the recommended settings (I may look into appending some instructions to fixing that there).

I would also look for some updates to your graphical drivers if those do not work. The second link Dubz posted can help you there. Smile
I fixed it! Turns out I had to replace several .dll files in System32 and SysWOW64. Anyway, thank you guys for offering help! Big Grin
That's... awfully strange. If that were the case, a reinstall should have fixed it. Huh, oh well, glad to hear you got it solved!

Since you have marked it as such, closing thread Smile
Enjoy the game!