Frictional Games Forum (read-only)

Full Version: Game won't init steam on 10.6
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Quote:[S_API FAIL] SteamAPI_Init() failed; ipcserver init failed .
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dylib.

"Could not init steam!"

My Steam ID is BSODM if relevant
Have you tried restarting Steam, or turning your computer off and on again?
I don't know - is the Steam version even supposed to work on 10.6. Like after all Steam has ended support for anything below 10.7

However the system requirements on the Steam page lists as minimum Mac OS X 10.5.8
In that case it might be an issue with Steam and not the game, and if so I don't think there's much we can do. Had the game been a retail copy it might've worked better since it wouldn't be dependent on Steam.

Are you able to run all other games on your current setup? I imagine some of them work fine, and that some specific functionality in the Steam client is what isn't supported, which it could look like Amnesia is using.
If the Mac Steam version has since been updated, there may be a Amnesia_NoSteam application you can run in the game's root, else it is likely an issue with Steam as Mudbill has said. As a Windows user, when it does occur for me, I end up resetting Steam's background service or by closing and reopening Steam by going offline and online again. What appears to be happening is that Amnesia is checking to see if Steam is running, and cancelling it from running if it seems Steam is not running.

Beyond what has already been suggested, if it is possible to reinstall Steam in case some dependancies have become corrupt or missing, that would be my next step. From there, I can't really offer much more help because I don't believe it to be an issue with Amnesia itself.
Additionally there is no way to run like this on PowerMAC.
PowerPC applications have been discontinued for 8 years if not more, so that's understandable. If possible, I would suggest updating your OS. 10.6 is quite old by now.