Frictional Games Forum (read-only)

Full Version: Steam version of Penumbra - Black Plague : Crash at first level.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2


quick update: using llvm 7.0.0 the game still crashes using either lib32-mesa (18.2.1) or lib32-mesa-git (18.3.0)
[quote pid='363786' dateline='1537824892']
(06-04-2018, 08:14 PM)jackdoe Wrote: [ -> ]It seems that you need disable optimizations (option -O0) when building the mesa packages, otherwise the game crashes at the vice.

Hi jackdoe, maybe you can help me. Mesa 18.2.0 is now in Arch's official repositories but the game still crashes at the vice (using LLVM v6.0.1 though).

I also tried to build mesa-git + lib32-mesa-git (18.3.0) from AUR but building the dependencies failed after hours so I removed the make dependencies and just used LLVM v6 instead of v8. That worked but now the game still crashes at the mentioned point. The building process uses meson, and I added optimization options like so just in case:

  export CC="gcc -m32 -O0"
  export CXX="g++ -m32 -O0"

Do you have any tips / ideas? Did you disable any in-game graphic options? Should I just wait for LLVM 7.x to reach Arch's official repos or won't that make a difference either?

You are my last hope as devs don't seem to be very active about this issue :-c

You need to edit /etc/makepkg.conf and add the "-O0" option flag to DEBUG_CFLAGS and DEBUG_CXXFLAGS respectively. Also to fasten up the building process of development version of mesa packages, install ccache package and enable it at makepkg.conf too.

I use binary built versions of development version of llvm. I do not build it myself because building it takes too much time. Even using ccache and SSD to help. (

I use aurutils-git to ease up installation of packages from AUR repository.

Insert this snippet to mesa-git and lib32-mesa-git PKGBUILD file.


I use this stanza to build the mesa-git package.

aur sync --ignore=llvm-svn,clang-svn,llvm-libs-svn --no-ver --force mesa-git

And this one to build the lib32-mesa-git package.

aur sync --ignore=llvm-svn,lib32-llvm-svn,clang-svn,lib32-clang-svn,lib32-llvm-libs-svn,llvm-libs-svn,mesa-git --no-ver --force lib32-mesa-git

If you have enough CPU cores, use this stanza to speed up building process.
export MAKEFLAGS="-j3"

I have 2 cpu cores; so when doing multiplication with 1.5 (2 * 1.5), I get 3.


Thanks a lot Mr. jackdoe!

That way it finally works, using LLVM from the official repos was no problem either!

Anyway dear devs, please consider fixing this bug for the sake of actual linux support as it will probably hit most linux users using AMD drivers
Pages: 1 2