Frictional Games Forum (read-only)

Full Version: Renderer #0 Error Windows 7
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hey people, I just upgraded my operating system from Windows XP SP3 to Windows 7 Ultimate x86 bit Edition, and now I get the infamous "Renderer #0 could not be initialized" error.

I know I can play this game, on XP I played it no problem with maximum settings.

System specs have not changed, only the operating system.


OS: Windows 7 Ultimate x86
CPU: Intel E6600 Dual Core (2.4 GHz)
RAM: 2.0GB
Video Card: nVidia 8800GTS

The drivers for my video card are up to date and are for Windows 7 64x.

No matter what I do, I get the Renderer #0 error unless I put the resolution as low as it can go (640x480) and turn off SSAO and Edge Smooth. And I am most certainly not going to play the game like that after having it working at 1680x1050 with maximum settings.

I've looked all over the internet for a solution to this. I can't find anything that has applied to my situation. It's not a matter of if I can run this game. I can, I can run this game in overdrive mode with no drop in FPS. It's just that ever since I changed my OS I get this stupid error.

I am using Steam just for the record. Always have been, even on XP.

I reinstalled my graphics drivers, went so far as to uninstall the default Windows 7 drivers for it, along with the nVidia drivers, then rediscover it and reinstalled the nVidia drivers. Still nothing.

Uninstalled the game completely from Steam and deleted all accounts of it from my computer except my profile information. Reinstalled everything...and I still get the error.

I get it loaded up every now and then after doing random things, but it's always laggy to the point where it's unplayable. Audio is never affected though, as is the case with other people who have lag like this.

I had it working ONCE with acceptable settings, but it was a little laggy. Went to turn my anti-aliasing from 8x to 4x (on my video card settings, not Amnesia settings) in an attempt to get rid of the lag and the Renderer #0 error returned. Put it back to 8x and the error stayed. Hasn't gone away since.

I've tried everything, no results. Along with everything, I have also tried running both Steam and the Amnesia launcher.exe as an Administrator and in Windows XP compatibility mode. The error comes along right on schedule.

Can Amnesia just not run correctly on Windows 7 86x with an 8800GTX? I know it works fine on 32x and 64x, and 86x is basically 64x...

It's driving me crazy, any help would be appreciated people. I signed up here to ask you guys out of desperation.

hpl is attached.
Perhaps try some different settings in the control panel for the graphics card. Could be a conflict between some settings, perhaps force vsync or so.
(03-20-2011, 12:49 PM)jens Wrote: [ -> ]Perhaps try some different settings in the control panel for the graphics card. Could be a conflict between some settings, perhaps force vsync or so.

Tried playing with every nVidia control panel setting, and Force vSync is off for both Amnesia settings and nVidia control panel.

Still getting that wonderful error.
Ooops nvm i didnt read everything you said, aha.....
(03-24-2011, 12:59 AM)Itskody Wrote: [ -> ]Ooops nvm i didnt read everything you said, aha.....

Saw email reply, all I know is you said something about maybe because I installed it on XP... o_O Anyway thanks for trying, also for the bump!

Still getting this lovely error guys, Amnesia is a masterpiece and I WANT TO FINISH IT SO BAD!

So many people are getting this error for so many different reasons, what the heck Frictional cmon! Massive respect to you guys but this is ridiculous! I'm not making any mistakes here, I have the latest drivers, my PC is perfectly capable of running this game, and I upgrade my operating system and I suddenly can't play it anymore...cmon seriously?

Anyone else got any ideas as to possible solutions?

It seems like this Error is saying that I can't get OpenGL to initialize...
Have you checked and verified everything in the trouble shooting guide?
(03-25-2011, 08:09 AM)jens Wrote: [ -> ]Have you checked and verified everything in the trouble shooting guide?

I have been through it extensively many times over.

At one point it suggests running the game in default resolution and SSAO and Edge Smooth turned off. If I do this I can successfully run the game.

But this is supposed to be a solution for people who are unable to run the game normally do to the limitations of their graphics card.

As I said, I have had this game running in 1680x1050 with every setting at maximum quality, and I had no problems whatsoever.

I know I have the right specs to run this game, I've done it outstandingly before. Although I can run the game at default resolution with quality settings at the bare minimum, I refuse to do so. If it was my only option and I couldn't play the game any other way, I would accept that but I've had this game working just fine in the past and I'm not going to sit and accept that I can never play a game the way I used to just because I upgraded my operating system.
Try turning off aero themes and effects before running the game and see if that helps.
(03-25-2011, 04:36 PM)jens Wrote: [ -> ]Try turning off aero themes and effects before running the game and see if that helps.

Just tried, still getting the Renderer #0 error.

I think I may have a problem running OpenGL on the newest nVidia drivers for my card. (GeForce 8800GTS)

Before when the game worked fine, I had outdated drivers that were installed from the disc that came with my graphics card. I tried to install those on my new Windows 7 OS, and Windows 7 won't accept them, says that the entire content of the driver disc is incompatible with Windows 7. So I had to download the latest drivers from nVidia's website for my card, and I think these new drivers won't let me play Amnesia.

Where can I download OpenGL drivers for the GeForce 8800 series cards? I thought I found one on nVidia's site but it just made my card stop functioning. Anyone know where the right one is?
Here you can find drivers all the way back to 2009
Pages: 1 2