Frictional Games Forum (read-only)

Full Version: Palistov needs your help! :)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Help me guys! This will take 5 mins! Not even! Smile

I've been having trouble with my custom models recently. People have reported not seeing them show up in my demo.

Attached is a link to a custom story that is just a map loaded up with my custom models. I'd like for you guys to extract it to your amnesia root. NOT \custom_stories\ ! Directly into your amnesia root. This will merge your entities, static_objects, and custom_stories folders. It will NOT replace any game files nor any other maps, etc. If it tries to say NO. Do not rename anything though, it will cause problems.

Also attached is a screenshot of what SHOULD show up in the map.


4 shirts: gold, teal, blue, green
2 items: stone bottle, grunt flesh
1 bed: it's a bed. durr
3 walls: cellarbase walls with a texture I got off of CGTextures.

Thanks SO MUCH!
I can see all 4 shirts, the walls, the floor and the grunt flesh (couldn't pick it up). The bed is invisible and the stone bottle isn't loaded at all.

You can put the static_objects and entities folders inside your custom story folder. Made no difference to me (tried both ways).

Amnesia crashed when I tried to look at the bed in Inspection Mode.
Alright thanks man! Yeah the stone bottle and bed have been giving me trouble. I'll upload another version in a few days. I think I'll just start from scratch with both the bed and bottle.

Kudos to you, sir!

I've tried having my custom models inside my story root, but when I opened the maps containing said models, they would disappear and I would get a warning that certain models (HRMM I WONDER WHICH ONES?) couldn't be loaded, and to check the log. Sad

This isn't much of a big deal though because I plan on just having my download file contain the same structure as this little 'demo' map and have players simply extract it directly to the amnesia root. This way they can not only avoid errors and invisible entities and such, but they can use my models for their own maps Smile
I just did my first model and I'm getting the same problem now. Thing is, it works in the mapview, but not in game. The entity also isn't grabable when it's supposed to be. So yea, I'm looking into it now.
(04-28-2011, 11:20 PM)MrBigzy Wrote: [ -> ]I just did my first model and I'm getting the same problem now. Thing is, it works in the mapview, but not in game. The entity also isn't grabable when it's supposed to be. So yea, I'm looking into it now.

You use 3DS right Bigzy?
I switched to Maya for my model.

Question, did you make your model and everything and then move it into the Amnesia folder after? It seems that's what caused it for me. The original one opens in modelview, but the one I copied and pasted into the new directory won't. Should of remembered that from the outsourcing tutorial... :V
Yeah that's what I did. I use Blender, so I already had to do a complex exporting process involving two different versions of Blender. After that I would store all of the texture and mesh files in my custom story root, create the .mat and .ent files, then copy and paste them into the amnesia game files. It apparently worked for my shirts and grunt arm, as well as the walls and floor, but for some reason the bed and bottle won't work. I'll try re-making the .ent and .mat files and see if that works, and make sure I create them directly into the Amnesia files.

By the way, when you create your entity in the ModelEditor, did you create a shape, then from that shape make the body? You need to create a body and give it physics properties or the game won't agree with it Sad I do believe it also needs a body to be able to be grabbed, otherwise it's just a floating texture of doom, haha.

Use the game's entities for reference; for example, I made my bed's body similar to the movable prison-style bed.
Yeah of course, for some reason it reset to StaticProp though, it's fixed now. Not the texture part though. D: Still looking into that. Can you go on steam so we can talk about it n stuff?

Edit: It just worked. I copied it over again and all was fine. Maybe it got corrupted? Not sure.
complex exporting process Big Grin
I think too its something with same name from the new bed and the original bed...
yeah make a body give it a mass and set under settings/user defined variables
object/grab and it should work
Sorry I wasn't able to IM chat with you MrBigzy. I had a laboratory class coming up so I had to pack up the computer hehe. Glad you got it working.

DonProtz, yeah I couldn't export straight from 2.57 Blender, so I had to save it as a .blend file, then open it in 2.49b and export it there. It's a tedious process but it works Big Grin By the way I see your stuff in the Showcase forum, it's great work, man.