Frictional Games Forum (read-only)

Full Version: [Solved]Full Conversion Still pointing to Default Directory
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I have modeled my own lantern and would like to replace the default one in my full conversion.

I placed the model in Dazed/models/hand_objects/lantern/dzd_hand_lantern/
There is a lantern.ho file located in Dazed/models/hand_objects/lantern

This is the lantern.ho file
        Model = "dzd_hand_lantern/dzd_hand_lantern.ent"
        Type= "LightSource"

        OffsetScale = "1 1 1"
        OffsetRotation = "-15 -5 -46"
        OffsetPosition = "-0.0105 -0.0035 0.002"
        HandsAnim_Idle = "Lantern_Idle"
        HandsAnim_Draw = "Lantern_Draw"
        HandsAnim_Holster = "Lantern_Holster"
        AttachBoneName = "attachpoint"
        FadeInTime = "1"
        FadeOutTime = "1"
        HasSwayPhysics = "true"
        MaxSwayVel = "15"
        SwayAngleLimits = "-13 90"
        SwayDownAngleLimits = "-7 80"
        SwayPinDir = "0 0 1"
        SwayGravity = "12"
        SwayFriction = "1.0"
        SwayPlayerSpeedMul = "0.015"
        SwayCameraRollMul = "1"
        SkipSwaySubMesh = "Handle"


I copied the hands over, and edited the hands.ent file
        <Performance CamClipPlanes="0.05 1000" LightsActive="true" PSActive="true" ShowFog="true" ShowSkybox="true" WorldReflection="true" />
        <ViewportConfig BGColor="0.2 0.2 0.2 1" GAmbientLight="true" GPointLight="true" GridSnap="false" GridSnapSeparation="0.25" SelectedViewport="3" UsingEnlargedViewport="true">
            <Viewport CameraPosition="0 0 20" CameraTarget="0 0 0" CameraZoom="0.916291" GridHeight="0" GridPlane="2" Preset="0" RenderMode="1" ShowAxes="true" ShowGrid="true" UsingLTCam="true" />
            <Viewport CameraPosition="20 0 0" CameraTarget="0 0 0" CameraZoom="0.916291" GridHeight="0" GridPlane="0" Preset="1" RenderMode="1" ShowAxes="true" ShowGrid="true" UsingLTCam="true" />
            <Viewport CameraPosition="0 20 0" CameraTarget="0 0 0" CameraZoom="0.916291" GridHeight="0" GridPlane="1" Preset="2" RenderMode="1" ShowAxes="true" ShowGrid="true" UsingLTCam="true" />
            <Viewport CameraPosition="0.752535 0.737806 0.224467" CameraTarget="-0.220334 0.049336 -0.228084" CameraZoom="3.66919" GridHeight="0" GridPlane="1" Preset="3" RenderMode="0" ShowAxes="true" ShowGrid="true" UsingLTCam="true" />
        <Entities />
        <Mesh Filename="Dazed/models/player/hands/hands.dae">
            <SubMesh Active="true" ID="0" Material="" Name="hand" Rotation="0 0 0" Scale="1 1 1" SubMeshID="0" Tag="" WorldPos="0 0 0" />
            <Animation File="animations/hands_lantern_idle.dae_anim" Name="Lantern_Idle" SpecialEventTime="0" Speed="1" />
            <Animation File="animations/hands_lantern_draw.dae_anim" Name="Lantern_Draw" SpecialEventTime="0" Speed="1" />
            <Animation File="animations/hands_lantern_holster.dae_anim" Name="Lantern_Holster" SpecialEventTime="0" Speed="1" />
    <UserDefinedVariables EntitySubType="" EntityType="PlayerHands" />

Whenever I attempt to bring the lantern up, the game crashes... What is going on? D:
Did you add the "Dazed" directory to the resources.cfg you are using?
Also, the animations are pointing to "animations/<file>" - so if this path doesn't exist that could be your problem. If you are replacing all the models, remove the listing of the models directory in the resources file - i believe it is specified in there twice for some reason, so perhaps a naming conflict error?

Also I don't know if paths have to be relative to the file you are using, the amnesia executable or whether the game completely ignores folders and just accesses stuff by file-name from the folders specified in resources.cfg (it certainly does that with any files used in scripting), so may be worth playing around with the paths.
I actually fixed this and forgot to report back D:

The problem was that I didn't define the new lantern model as a hand object.

It loads now, I see Daniel's hands, I see the light that comes from the lantern, but I do not see the lantern itself...

It loads up fine in the model viewer and I'm starting to tear my hair out.
I suppose this can show my current desktop and frustration

[Image: 8Iyip.jpg]
Can u show me full picture of lantern 4 curiosity?
thanks in advance if you do.
Question, when you first start the game and the lantern is missing, if you look behind you at where you start, do you see it floating in the air or sitting on the ground?

Edit: Actually, yea, that should be exactly what happened. Unfortunately, you can't have bodies in your ent file or it'll screw it up. For your lantern, you don't need it anyway. The .ho file specifies the handle as the sway pivot point. Just make sure the SkipSwaySubMesh is the name the handle has.

I've been trying to find a way to make it work... :V
I actually solved this without reporting back D:

Yeah MrBigzy, I suppose that was the problem, not entirely sure because I just redid everything and it worked D: