Frictional Games Forum (read-only)
Issue with Penumbra: Overture and large partitions. 64-bit inodes. - Printable Version

+- Frictional Games Forum (read-only) (
+-- Forum: Technical Support (
+--- Forum: Technical Support - Penumbra Series (
+---- Forum: Linux - Penumbra (
+---- Thread: Issue with Penumbra: Overture and large partitions. 64-bit inodes. (/thread-21705.html)

Issue with Penumbra: Overture and large partitions. 64-bit inodes. - mguiddy - 06-03-2013

Are there any known issues with Penumbra: Overture (I'm using the direct download version from Humble Bundle) running on XFS filesystems? or perhaps a large partition?

I've been using XFS for years and have run an earlier Overture demo on an earlier version of OpenSuSE (which should've been running XFS), but on my new system, it won't start if I have it installed on my 2.63 TB XFS partition.
Having recently experienced a similar issue with Steam, I tried moving it to my 100 GB EXT4 partition and the game runs fine now.

The issue I would receive when attempting to run on the larger XFS partition was the "Couldn't Load PointLight2D" error.
Searching pointed out that error occurs if the game is run from the wrong directory or the file is missing. I was running the game from the correct directory and the file was there, so I knew something else was wrong.
Because of the issue with Steam I recently experienced (which involved Steam not being able to verify files on XFS), I thought I'd try moving the game to the EXT4 partition and viola, it ran.

So, I decided to do another test.
I moved the Penumbra: Overture directory to an old ~900 GB XFS drive (formatted on install of OpenSuSE 12.1) and it ran fine.
So, to me, it seems the issue must be with the large size of the partition or partition size coupled with XFS. Unless there's some issue with XFS formats done with the version of XFS that ships with OpenSuSE 12.3 (which is my current distro and the 2.63 TB drive was formatted on install).
If I can find a spare drive I'll try to format it on my current system to see if the problem persists.

Perchance an issue with the 64-bit inodes?
From what I've been reading, 64-bit inodes are most likely the issue... Probably the issue I had with Steam as well.

Oh well, unless someone else wants to test/chime in, I would say this is solved.

Hopefully the info helps someone else in the future. Big Grin