Frictional Games Forum (read-only)
Xbox Controller dont work - Printable Version

+- Frictional Games Forum (read-only) (
+-- Forum: Technical Support (
+--- Forum: Technical Support - SOMA (
+---- Forum: Linux - SOMA (
+---- Thread: Xbox Controller dont work (/thread-31129.html)

Xbox Controller dont work - ufz - 10-02-2015


i have kubuntu 14.04.3. And the "valve" xbox driver.
the game pad works on system settings. the program antimicro (map keys to gamepad) works too.

But soma does not. how can i tell soma to use my gamepad?


sudo apt-add-repository ppa:rael-gc/ubuntu-xboxdrv

sudo apt-get update && sudo apt-get install ubuntu-xboxdrv

RE: Xbox Controller dont work - jens - 10-02-2015

Don't have a solution but had troubles getting gamepad to work with one install and tried "valve" xboxdriver as well as another driver. Both worked in the system but did not work with SOMA. I did a clean install of a system and then SOMA worked perfect with the default gamepad driver. After that I also tested using the "valve" xboxdriver and it worked as well. So something can break the functionality, but I don't know how/what to do to fix it.

RE: Xbox Controller dont work - Guest - 10-05-2015

Okay after deleting "valve" driver. and the commands:

sudo modprobe joydev
sudo modprobe xpad

its working again. could it have some thing to do with this commands? are these commands working also with
the valve driver?