Frictional Games Forum (read-only)
CRITICAL BUG, HELP very much wanted - Printable Version

+- Frictional Games Forum (read-only) (
+-- Forum: Amnesia: The Dark Descent (
+--- Forum: Custom Stories, TCs & Mods (
+---- Forum: Technical Support (
+---- Thread: CRITICAL BUG, HELP very much wanted (/thread-53910.html)

CRITICAL BUG, HELP very much wanted - Darkfire - 10-06-2017

Hello guys (Is there anybody still here?).

For the third time I've received some very disconcerting bug reports about my first mod, Chromanin (LINK), and I'm in a knot here. I can't think of anything that might fix the bug.

The game seems to load a wrong map; After a huge chunk of the mod the player comes back to a previously visited location (map name: "sypialnia"). Leaving it should lead to a hub level (map name: "Level2")(which has also been previously visited). However for some people a different level loads (map name: "SecretLevel1"), a one that mustn't be revisited - it might render the mod unfinishable.

Obviously I have beta-tested this level countless times (seriously, I'm really fed up with it), and on my computer it always works. The level exit is a LevelDoor which points to the correct map.

Here are the first-hand descriptions of the phenomena:
Spoiler below!
"So I exited off, but after loading Outside map, the game loaded me into Dungeons without any remorse. I tried to repeat this location again, but with same result. My friend was playing with me on another computer and he had this bug too. I don´t know what´s just happened, but it was really annoying, we spend probably an hour to resolve this and finally I managed to fix this by using another bug in forest."
I can't really tell how they fixed that, as they claim that they have fixed the bug by using a completely differet level (like, what the hell ???).

Spoiler below!
"Yep that's right i leaved through the red door and then im in the dungeon not in the outside area. Im going to replay the mod maybe its a one time thing. " (No further comments)

Spoiler below!
"So i finished the Underworld parts and now im back in Aiden apartment but when im try to exit from the apartment the game teleport me back in to the doungeons. I dont now whats the problem i have the 1.3 patch and everything"

Please, help me with this if you have any ideas. I'm kinda in despair with this one.

RE: CRITICAL BUG, HELP very much wanted - Romulator - 10-07-2017

Are any of your ChangeMap() scripts which dictate which map to go to, handled by a string variable? At some point in time, you may cause a logic error if you don't do certain requirements.

For example, level_1 can go to level_2 or level_3 via the same door, because it is a magic door. The same thing happens on level_2, where it can take you to 4 or 5. Setting the variable to 2, but in level_2, not doing a certain objective, or doing one multiple times, could end up taking you to any level.

Think about how it's possible for the bug to occur; map name conflicts, variables, Level Editor entity settings, etc.

You should get a hold of their hpl.log files after the bug occurs. You can get a rough idea of what they did and how they ended up where they ended up.

RE: CRITICAL BUG, HELP very much wanted - 7heDubz - 10-07-2017

I still open up the new posts tab every single time I open my browser tbh.

RE: CRITICAL BUG, HELP very much wanted - Darkfire - 10-07-2017

Level editor (door) entity setting is 100% correct.
Map name conflict might occur, but with different stories only (noone has ever reported this though).

I'm not sure what you mean in the second paragraph. Are you implying that the entity settings of a LevelDoor can change themselves ?

I'll try to get a hold of an hpl.log. However that would require the players to replay the mod, which might be a little hard to convince them to do (as I mentioned, I can't recreate the bug on my computer).

I thought of using ClearSavedMaps(); This would however break the game, because Level2 is used throughout the whole story and deleting it's save might be problematic.
Similar case with If I used that script, the player would be trapped inside that map.

I can throw in that the map layout looks like this:

[Image: PW6h7xI.png]

Don't mind the red line, I'll explain that more clearly here. Maps are in this order:
1. Intro
2. First visit to
3. First visit to Level2 (the Hub)
4. Explore Level3 and Shedlevel, while going in& out of Level2(Hub)
5. Enter via script
6. Complete about 4 maps inbetween
7. Go back to via script
8. Leave via LevelDoor
9. Should end up in Level2, end up in instead

Here I should mention that in an old version (the one which the people I quote played) nothing stopped the player from entering again after completing it.

Now there's a GlobalVariable, which is set to 1 when player enters a certain area in SecretLevel1, which blocks the ChangeMap script from Level2.

RE: CRITICAL BUG, HELP very much wanted - Mudbill - 10-10-2017

What if you rename the maps to something completely different? Perhaps try to get ahold of someone who's had this problem so you can test it.