Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Search Results
Post Author Forum Replies Views Posted [asc]
    Thread: Sound won't loop.
Post: Sound won't loop.

I have a sound that's supposed to loop but it won't loop. I've set in the .snt file "Loop=True" but it just stops at the end of the sound. Also, the volume of the sound doesn't change when I change th...
Spazatron Development Support 3 2,687 04-10-2015, 07:21 PM
  Rainbow Thread: Entity won't activate.
Post: RE: Entity won't activate.

(10-29-2014, 08:04 PM)Mudbill Wrote: Did you try adding a AddDebugMessage script next to it and check if it's running? Is the name actually matching the level editor and script? Yes and yes. Still n...
Spazatron Development Support 6 5,160 10-29-2014, 08:16 PM
    Thread: Entity won't activate.
Post: RE: Entity won't activate.

(10-29-2014, 07:15 PM)Mudbill Wrote: If the entity is a StaticProp entity, it won't work to disable it. What entity are you trying to do this with? I'm trying to do it with an Item (something you ca...
Spazatron Development Support 6 5,160 10-29-2014, 07:20 PM
    Thread: Entity won't activate.
Post: Entity won't activate.

I have an entity that needs to be activated at a certain point with SetEntityActive. I have pretty much the exact same script elsewhere in the game and it works fine, but this time it doesn't want to ...
Spazatron Development Support 6 5,160 10-29-2014, 07:12 PM
    Thread: Why don't new entities load?
Post: Why don't new entities load?

Say I have a game save in a map on my custom story, then I go into the Level Editor and add a new entity, for example a note. Why, when I reload that game save, does the entity not show? And I must re...
Spazatron Development Support 2 2,274 10-28-2014, 03:05 PM
    Thread: Dev mode help?
Post: Dev mode help?

I'm loading the debug menu (menu that's opened with F1) while I'm testing my custom story. I need this so that if I make any changes to scripts or maps, I can quickly reload them. But it resets my var...
Spazatron Development Support 3 2,549 10-28-2014, 02:48 PM
    Thread: Problem with door closing
Post: RE: Problem with door closing

(10-13-2014, 05:39 PM)FlawlessHappiness Wrote: You've got the idea, but you forgot to check if it's true or false that you have it... if you go here: http://wiki.frictionalgames.com/hpl2/amn..._fun...
Spazatron Development Support 9 6,504 10-13-2014, 06:03 PM
    Thread: Problem with door closing
Post: Problem with door closing

I have a script where if the player goes through an area where a door is, and has certain items in their inventory, the door will close and lock itself behind them. When they go through the area, I'm ...
Spazatron Development Support 9 6,504 10-13-2014, 05:18 PM
    Thread: Level editor sounds
Post: RE: Level editor sounds

(10-11-2014, 05:16 PM)FlawlessHappiness Wrote: Depends on how you play it. Music can only play one at a time. Multiple Sounds can play at a time. You say it has been set up correct, but since it...
Spazatron Development Support 3 3,352 10-11-2014, 05:24 PM
    Thread: Level editor sounds
Post: Level editor sounds

I created two sounds in the Level Editor, but only one actually plays. All the files are set up correctly and whatnot... can I only play one sound at a time?
Spazatron Development Support 3 3,352 10-11-2014, 05:11 PM
    Thread: if statement isn't working
Post: RE: if statement isn't working

(10-05-2014, 06:24 PM)Wapez Wrote: Try using SetGlobalVarInt("SwitchBack", 1); instead. EDIT: NVM, you need to put the if statement in the OnEnter() Function instead, OnStart is only used the firs...
Spazatron Development Support 2 2,880 10-05-2014, 07:18 PM
    Thread: if statement isn't working
Post: if statement isn't working

I have a note that when you finish reading, teleports you to a new map. This is a map that the player will have already been in before, therefore I need to tell the script that the player is revisitin...
Spazatron Development Support 2 2,880 10-05-2014, 06:18 PM
    Thread: Development environment bug?
Post: RE: Development environment bug?

(10-05-2014, 06:03 PM)FlawlessHappiness Wrote: That has nothing with the enviroment to do. You must've made an error in your .lang file. That's why the whole thing won't work. I've checked my .lan...
Spazatron Development Support 3 2,964 10-05-2014, 06:07 PM
    Thread: Development environment bug?
Post: Development environment bug?

I set up a development environment using this tutorial: https://wiki.frictionalgames.com/hpl2/am...evenvguide ...and now SetMessage doesn't work. Is there a setting I need to change for the messages ...
Spazatron Development Support 3 2,964 10-05-2014, 05:17 PM
    Thread: Particle collision
Post: Particle collision

I have a rain particle to make it look as though it's raining outside a window, but the rain is going through the ceiling of another room in the building. I can't simply move the particle because it's...
Spazatron Development Support 2 2,449 10-04-2014, 01:13 PM
    Thread: Script after note is read?
Post: RE: Script after note is read?

(10-02-2014, 03:48 PM)Mudbill Wrote: It actually happens AS you pick it up. If you for example play a sound effect, it will play instantly, even while the note is open. Here's a trick: Timers freez...
Spazatron Development Support 5 4,264 10-04-2014, 11:49 AM
    Thread: Script after note is read?
Post: RE: Script after note is read?

(10-02-2014, 01:50 PM)Neelke Wrote: Yes. When you click the entity there's something named CallbackFunc. In there write the name of the function you want to execute. In the script you write this. ...
Spazatron Development Support 5 4,264 10-02-2014, 02:14 PM
    Thread: Script after note is read?
Post: Script after note is read?

Is there any way to execute a script after a note has been closed?
Spazatron Development Support 5 4,264 10-02-2014, 01:13 PM
    Thread: Custom entities stopped working.
Post: RE: Custom entities stopped working.

(09-29-2014, 08:35 PM)Daemian Wrote: And make sure your mod is mentioned in your [game dir]/resources.cfg or a parent. Why is that so? I've never had to do that with a custom story before... :S UPD...
Spazatron Development Support 4 3,452 09-29-2014, 09:37 PM
    Thread: Custom entities stopped working.
Post: Custom entities stopped working.

I wanted a grunt without the grunt's music playing, so I opened the grunt in Model Editor and changed the settings so the music was gone, then saved it in a folder called "entities" inside of my custo...
Spazatron Development Support 4 3,452 09-29-2014, 06:34 PM