The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 906 - File: showthread.php PHP 7.2.24-0ubuntu0.18.04.17 (Linux)
File Line Function
/showthread.php 906 errorHandler->error



Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Penumbra: Overture not running.
LogansRun22 Offline
Junior Member

Posts: 2
Threads: 1
Joined: Feb 2013
Reputation: 0
#1
Solved: 8 Years, 4 Months, 3 Weeks ago Penumbra: Overture not running.

I am another one of the many people for whom Penumbra: Overture is not working. I downloaded the Penumbra Collection through Steam and I use Linux Mint 13 64-bit.

Here is the output to my ~/.frictionalgames/Penumbra/Overture/hpl.log:

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
  Max texture image units: 8
  Max texture coord units: 8
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 4
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 160583208
  ATI Fragment Shader: 0
Creating graphic systems
  Creating Renderer2D
  Renderer2D created
  Creating Renderer3D
   Load Renderer3D gpu programs:
    Extrude
CG: 'ShadowExtrude_vp.cg' using profile: 'arbvp1'
CG: 'ShadowExtrude_fp.cg' using profile: 'arbfp1'
    Diffuse Vertex
CG: 'Diffuse_Color_vp.cg' using profile: 'arbvp1'
    Diffuse Fragment
CG: 'Diffuse_Color_fp.cg' using profile: 'arbfp1'
    Fog
CG: 'Fog_Solid_vp.cg' using profile: 'arbvp1'
CG: 'Fog_Solid_fp.cg' using profile: 'arbfp1'
   Creating fog textures: Solid Additive Alpha
CG: 'refract_vp.cg' using profile: 'arbvp1'
CG: 'refract_fp.cg' using profile: 'arbfp1'
CG: 'refract_special_fp.cg' using profile: 'arbfp1'
   init sky box
  Renderer3D created
Creating screen buffers size 800.000000 : 600.000000
Creating programs
CG: 'PostEffect_Blur_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Blur_Rect_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Blur_2D_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Bloom_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Bloom_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Motion_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Motion_fp.cg' using profile: 'arbfp1'
The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(28) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
CG: 'PostEffect_Motion_staticloop_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_DoF_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_DoF_fp.cg' using profile: 'arbfp1'
  RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
  Trying to open audio device... Success!
  Device name: PulseAudio Default
  Number of mono sources: 32
  Vendor name: OpenAL Community
  Renderer: OpenAL Soft
  OpenAL Version Supported: 1.1
  EFX: 0
  Output Devices:
    PulseAudio Default
    Built-in Audio Analog Stereo via PulseAudio
    ALSA Default
    HDA Intel [AD198x Analog] (hw:0,0) via ALSA
    HDA Intel [AD198x Digital] (hw:0,1) via ALSA
    No Output
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
WARNING: Language entry 'EventKeyInNoPower' in category '01_10_small_shaft' already exists!
Initializing Penumbra: Overture
  Version    $Rev: 3033 $
  Date    $Date: 2010-12-12 21:46:28 +0000 $
Checking Supported Profiles
  Profile CG_PROFILE_VP20 is supported
  Profile CG_PROFILE_ARBVP1 is supported
  Profile CG_PROFILE_ARBFP1 is supported
Trying to load vertex program!
CG: 'Test' using profile: 'arbvp1'
Success!
CG: 'DiffuseSpec_Light_vp.cg' using profile: 'arbvp1'
CG: 'DiffuseSpec_Light_Spot_vp.cg' using profile: 'arbvp1'
CG: 'BumpSpec_Light_fp.cg' using profile: 'arbfp1'
CG: 'BumpSpec_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Ambient_Color_fp.cg' using profile: 'arbfp1'
WARNING: Texture 'startup_ooo_logo.jpg' does not have a pow2 size!
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading collada for 'maps/level00_01_boat_cabin.dae' took: 180 ms
CG: 'Fog_Trans_vp.cg' using profile: 'arbvp1'
CG: 'Fog_Trans_Alpha_fp.cg' using profile: 'arbfp1'
CG: 'Diffuse_Light_vp.cg' using profile: 'arbvp1'
CG: 'Diffuse_Light_Spot_vp.cg' using profile: 'arbvp1'
CG: 'Diffuse_Light_fp.cg' using profile: 'arbfp1'
CG: 'Diffuse_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Bump_Light_fp.cg' using profile: 'arbfp1'
CG: 'Bump_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Fog_Trans_Mod_fp.cg' using profile: 'arbfp1'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
CG: 'BumpColorSpec_Light_fp.cg' using profile: 'arbfp1'
CG: 'BumpColorSpec_Light_Spot_fp.cg' using profile: 'arbfp1'
WARNING: Bone 'joint1' is not attached to skin!
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
ERROR: Child body 'joint1' for joint 'sjoint2' in mesh 'boat_dynamicparaffin.dae' does not exist!
ERROR: Cannot find sub entity 'parrafinlight_joint1' in mesh 'boat_dynamicparaffin.dae'
Loading map 'level00_01_boat_cabin.dae' took: 1957 ms

Some additional notes:
- I have installed ia32-libs.
- I have tried to install the patch, however, I don't know where to put it. The script wants to put it in ~/PenumbraCollection, which doesn't exist on my system. I searched for Penumbra via Nautilus and it gave me /proc/2436/cwd/SteamApps/common/Penumbra Overture, which seems to imply that even though I purchased the Collection all in one go on Steam, I have the three individual games installed on my system separately, but I want to be sure before I install the patch.

EDIT:
The crash that occurs is the same as what others seem to be experiencing: I can watch the intro video, and then it goes to black screen and I have to Ctrl-Alt-Backspace to log out and back in to unfreeze the computer.
(This post was last modified: 02-24-2013, 08:24 PM by LogansRun22.)
02-24-2013, 08:06 PM
Find


Messages In This Thread
Penumbra: Overture not running. - by LogansRun22 - 02-24-2013, 08:06 PM
RE: Penumbra: Overture not running. - by Urkle - 02-24-2013, 11:31 PM



Users browsing this thread: 1 Guest(s)