Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Install script won't run
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#6
Solved: 9 Years, 6 Months, 3 Weeks ago RE: Install script won't run

(09-19-2013, 09:05 PM)Overand Wrote:
(09-19-2013, 08:22 PM)Urkle Wrote: --SNIP--
I'll be tweaking the startup portion of that to stop assuming that /tmp is executable (which frankly a LOT of installers make that assumption.

Yes, this is true - I think the /tmp set to non-executable thing is mostly a convention on servers moreso than workstations, but I'm probably not the ONLY person out there with that going on, heh. I would have figured it out quicker if the error had been a bit more verbose (such as including the full path of where it was failing to run).

Yeah I need to pull in more of the makeself customizations from nixstaller over. As there are checks for this in there.

Or I just make it NOT use tmp at all.. it's only extracting out 1 MB max.. as it it references the original .sh to fetch the "install.zip" that was appended to itSmile

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
(This post was last modified: 09-19-2013, 10:08 PM by Urkle.)
09-19-2013, 10:01 PM
Website Find


Messages In This Thread
Install script won't run - by salass00 - 09-10-2013, 10:20 AM
RE: Install script won't run - by Akasu - 09-10-2013, 06:14 PM
RE: Install script won't run - by Overand - 09-11-2013, 03:08 AM
RE: Install script won't run - by Urkle - 09-19-2013, 08:22 PM
RE: Install script won't run - by Overand - 09-19-2013, 09:05 PM
RE: Install script won't run - by Urkle - 09-19-2013, 10:01 PM



Users browsing this thread: 1 Guest(s)