Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Frameworks not found compiling in Mountain Lion
jorgeas80 Offline
Junior Member

Posts: 21
Threads: 7
Joined: Jan 2014
Reputation: 0
RE: Frameworks not found compiling in Mountain Lion

Actually, I've had to replace all the SDL includes with:

#include <SDL/SDL_xxxx.h>

That way, I've been able to compile OALWrapper. I've also installed SDL and SDL2 frameworks. Using SDL. Should I use SDL2?

Compiling with cmake, I get this error (Tried with XCode too, same result). I think that's positive. It's an error in the HPL1Engine, when including angelscript.h

This error:

error: no viable conversion from 'int' to 'asUPtr'
                return 0;

This is the code

struct asSMethodPtr
    template<class M>
    static asUPtr Convert(M Mthd)
        // This version of the function should never be executed, nor compiled,
        // as it would mean that the size of the method pointer cannot be determined.
        // int ERROR_UnsupportedMethodPtr[-1];
        return 0;

Of course, return 0 causes a problem, because it's returning an integer, instead of an asUPtr element.

But I see that code should not be compiled, and it's inside a ifndef:


Sounds like AS_NO_CLASS_METHODS is not defined, and that causes the problem. I'm probably using an old (or too new?) version of angelscript.h. It was included in a zip called dependencies, that I got from here

Am I missing something?

About the OS, I can use Mac OS Mountain Lion + XCode 5 (or XCode 4.6, I have both), Windows 7 + Visual Studio 2010 or Ubuntu 12.04 + usual coding stuff. I prefer Mac, but, which would be the recommended environment to work?
(This post was last modified: 01-07-2014, 05:55 PM by jorgeas80.)
01-07-2014, 05:31 PM
Website Find

Messages In This Thread
RE: Frameworks not found compiling in Mountain Lion - by jorgeas80 - 01-07-2014, 05:31 PM

Users browsing this thread: 1 Guest(s)