Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Model Editor Help 1 submesh works, the other ignores its body
WALP Offline
Posting Freak

Posts: 1,221
Threads: 34
Joined: Aug 2012
Reputation: 45
1 submesh works, the other ignores its body

I have created a fence gate, it has 2 submeshes.
Spoiler below!
[Image: MWIqU.jpg]
When I assign both of them to each their own body, one submesh will work fine, while the other will simply ignore the movements of the body its assigned to. When placing the fence gate in-game the submesh that is not assigned teleports to the center of the map while the body it should follow stays and works like it should.
Spoiler below!
[Image: 5V7qg.jpg]
the left image shows how the movement of the body is being ignored by the submesh(model-editor), and the right image shows how this causes the submesh to teleport to the center of the map(in-game)

I have tried a million things to fix it, without succeeding and I'm completely clueless now.
So I come here begging for help

I have done the following to fix the issue:
1. tried re-exporting and moving the submeshes appart.
Moving the submeshes proves to have no effect at all.
Re-exporting will sometimes switch the roles of the 2 submeshes
so the one that previously worked is now broke and the broken one now works.

2. Made completely 800% sure that it was attached in the model editor as well as already having the same settings as the castle door entity

3. Used different textures for each submesh
(and therefore also materials since HPL2 creates a new mat for every texture):
This has no effect

4. Changed Pivot/anchor point for the meshes
this only fucked up the locations of the submeshes.

5. tried creating a test model to test if the issue was just this
one object, or all objects I create. The issue was found on the test model as well.

6. Searched the forum OFC.

7. deleted map catche OFC. too.

I'm using blender 2.63 to export my models and I'm starting to think that the source might be the problem.
Though 2.64 is even worse for exporting(wont load).
I'm providing a download hoping those smarter then I will take a look.
If someone uses maya or 3dsmax, I'm curious as to whether or not it will work if its exported from one of those software, instead of blender(import dae. file and export it).


Note: To test if its working proberly open it in the model editor, make it a swingdoor. attach each submesh to their own body and make sure it has mass. Turn on "show physics debug info" and see if the submeshes follows their body like they should. If the body moves without the submesh the issue is still there.
12-18-2012, 11:19 PM
Your Computer Offline

Posts: 3,456
Threads: 32
Joined: Jul 2011
Reputation: 235
RE: 1 submesh works, the other ignores its body

Blender 2.64 is actually better for HPL2, since they finally export both IDs and names for the meshes in the DAE file. These names are required for the entity bodies to attach to the meshes. Therefore with Blender 2.64 you don't have to worry about entity bodies not attaching to the meshes and you don't have to worry about manually editing the DAE file to include names. However, in Blender 2.64 they added extra export options for COLLADA export that may confuse people who are not familiar with Blender (i'm not unfamiliar with these export options, so they're not an issue for me). The wiki explains the issues one can come across and how to solve them: http://wiki.frictionalgames.com/hpl2/thi...3d/blender

Tutorials: From Noob to Pro
12-19-2012, 12:51 AM
Website Find
WALP Offline
Posting Freak

Posts: 1,221
Threads: 34
Joined: Aug 2012
Reputation: 45
RE: 1 submesh works, the other ignores its body

I guess I must have given up a bit too quickly on 2.64 then, thanks a lot for replying it is highly appreciated :)
12-19-2012, 02:30 PM

Users browsing this thread: 1 Guest(s)