Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Xbox Controller dont work

Solved: 5 Years, 9 Months ago Xbox Controller dont work

i have kubuntu 14.04.3. And the "valve" xbox driver.
the game pad works on system settings. the program antimicro (map keys to gamepad) works too.

But soma does not. how can i tell soma to use my gamepad?


sudo apt-add-repository ppa:rael-gc/ubuntu-xboxdrv

sudo apt-get update && sudo apt-get install ubuntu-xboxdrv
10-02-2015, 01:36 PM
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
Solved: 5 Years, 9 Months ago RE: Xbox Controller dont work
Don't have a solution but had troubles getting gamepad to work with one install and tried "valve" xboxdriver as well as another driver. Both worked in the system but did not work with SOMA. I did a clean install of a system and then SOMA worked perfect with the default gamepad driver. After that I also tested using the "valve" xboxdriver and it worked as well. So something can break the functionality, but I don't know how/what to do to fix it.
10-02-2015, 02:07 PM
Website Find

Solved: 5 Years, 9 Months ago RE: Xbox Controller dont work
Okay after deleting "valve" driver. and the commands:

sudo modprobe joydev
sudo modprobe xpad

its working again. could it have some thing to do with this commands? are these commands working also with
the valve driver?
10-05-2015, 04:16 PM
Jump to the post that solved this thread.

Users browsing this thread: 1 Guest(s)