Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
can't get Amnesia to run (missing libalut.so.0)
3dfx Offline
Junior Member

Posts: 2
Threads: 1
Joined: Feb 2011
Reputation: 0
Solved: 5 Years, 10 Months, 3 Weeks ago can't get Amnesia to run (missing libalut.so.0)

I switch to sabayon from ubuntu a ways back
and ever since I can play Amnesia

when I go to start the game I git this
Quote:./Amnesia.bin64: error while loading shared libraries: libalut.so.0: wrong ELF class: ELFCLASS32

ok so then I looked in the sabayon package manager for libalut.so.0
and it dose not have it
so then I Googled it and I can't find it ether

any one know were I can get it
and how to install it
02-27-2011, 10:59 PM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
Solved: 5 Years, 10 Months, 3 Weeks ago RE: can't get Amnesia to run (missing libalut.so.0)

did you copy the game over from another system? or did you reinstall from scratch?

You can try running the "checklibs64.sh" that is in the game install directory so it will "relink" the included libs. (as libalut.so.0 is included)

It seems the issue you have is the libalut is a 32bit libalut instead of a 64bit libalut. libalut is usually part of the "freealut" package.

If the checklibs script doesn't work then it's probably confused by the fact that you have libalut somewhere in the library path and the linker is incorrectly pulling the 32bit lib for the 64bit application. You'll need to hunt that down and remove it. Or manually link the library.
cd /path/to/Amnesia/libs64/
ln -s all/libalut.so.0 libalut.so.0

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
02-28-2011, 03:10 PM
Website Find

Users browsing this thread: 1 Guest(s)