Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Terribly low FPS in Requiem Level 6 @ Radeon HD4670
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#1
Solved: 5 Years, 10 Months, 2 Weeks ago Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Hello,

at first I'd like to thank You for creating such a great game.

I've finished both Overture and Black Plague with no greater graphical problems (some flickering in BP). Now I'm playing Requiem and everything was fine until I entered level 6 (Power Station). Suddenly the game runs terribly slow, just few FPS (max 5 IMHO). I'm using Windows 7 x64, Athlon 64 3200 and 4GB of RAM. There was no problem with Requiem until this level.

I've applied all the patches and beta ATI Hotfix but none of them helped.
Switching all of the graphical settings to the lowest changed nothing also.

I've also done this:

Quote:General:
- Uninstall _all_ display drivers and then download and install the latest.

ATI control panel:
- Disable Catalyst AI (meaning the box shall be checked).
- Disable Triple buffer (box is unchecked).
- Wait for vertical refresh: "Off, unless applications specifies".
- Adaptive AA off (box is unchecked).
- Smooth vision HD (both). Box "Use application settings" is checked.

Windows:
- Disable Aero or any other composite/extra graphical touches technology that might be active.

With no effect.

I'm running on ATI Catalyst 9.12 driver.

I've moved to the corridor as I thought that this shiny, spinning ball was causing the problem some way but it didn't help too.

Has anyone encountered something like this? Is there any solution for this situation?
(This post was last modified: 01-05-2010, 08:34 PM by Rex.)
01-05-2010, 08:33 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#2
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

This is probably a CPU issue that happens on some systems. Try turning down resolution, etc to make graphics as fast as possible and also make sure no programs are running in the background.
01-06-2010, 09:39 AM
Find
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#3
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Quote:Try turning down resolution, etc to make graphics as fast as possible and also make sure no programs are running in the background.

I've turned down graphics settings to the lowest, including resolution. Nothing changed. And there are no programs working in the background.

But if it would be an CPU issue then why would it occur only at this level? I think it's connected with Radeon GPU. There were other issues occuring only Radeon HD cards, many people described them on this board. I think this is just a next one on the list of those.
(This post was last modified: 01-06-2010, 01:42 PM by Rex.)
01-06-2010, 11:55 AM
Find
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#4
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

I'm planning to go back to Windows XP and I'm gonna test Requiem on this OS. This will give information about one of the possible cause of such games behaviour.
01-07-2010, 12:31 AM
Find
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#5
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Ok, changing Windows to XP x64 changed nothing. The situation is exactly the same.
I've forgot to mention that there are no boxes in the tunnel and the boxes are needed to hit the ball.

And this is my log:

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 640 x 480 - 32 bpp
Init Glee...OK
Setting up OpenGL
  Max texture image units: 16
  Max texture coord units: 16
  Two sided stencil: 1
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 16
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 11
  ATI Fragment Shader: 1
Creating graphic systems
  Creating Renderer2D
  Renderer2D created
  Creating Renderer3D
   Load Renderer3D gpu programs:
    Extrude
    Diffuse Vertex
    Diffuse Fragment
    Fog
   Creating fog textures: Solid Additive Alpha
   init sky box
  Renderer3D created
Creating screen buffers size 640.000000 : 480.000000
Creating programs
CG ERROR : The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(32) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
  RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
  Trying to open software device... Success!
  Device name: Generic Software
  Number of mono sources: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
Initializing Penumbra: Black Plague
  Version    $Rev: 2595 $
  Date    $Date: 2008-05-03 15:09:49 +0200 (lö, 03 maj 2008) $
Checking Supported Profiles
  Profile CG_PROFILE_ARBVP1 is supported
  Profile CG_PROFILE_ARBFP1 is supported
  Profile CG_PROFILE_GLSLV is supported
  Profile CG_PROFILE_GLSLF is supported
  Profile CG_PROFILE_GLSLC is supported
Trying to load vertex program!
Success!
WARNING: Could not find language file entry 'PreMenuText'
All set up done, starting game!
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading collada for 'expansion01/maps/level06.dae' took: 2029 ms
ERROR: Couldn't create SoundEntity ' .snt'
WARNING: Couldn't preload sound ' '
ERROR: Couldn't create SoundEntity ' .snt'
WARNING: Couldn't preload sound ' '
ERROR: Couldn't create SoundEntity ' .snt'
WARNING: Couldn't preload sound ' '
ERROR: Couldn't create SoundEntity ' .snt'
WARNING: Couldn't preload sound ' '
ERROR: Couldn't create SoundEntity ' .snt'
WARNING: Couldn't preload sound ' '
WARNING: Texture 'blinn6-fx' was not found!
WARNING: Texture 'blinn6-fx' was not found!
WARNING: Texture 'blinn8-fx' was not found!
WARNING: Texture 'pasted__pasted__pasted__portal1-fx' was not found!
ERROR: No shapes for submesh 'BoxShape' with group: 'group2' in mesh 'gameplay_box_lever.dae'
Lever 'eleclever01' loaded state: 1
Lever 'lever01' loaded state: 2
Lever 'lever010' loaded state: 2
Lever 'lever011' loaded state: 2
Lever 'lever012' loaded state: 2
Lever 'lever02' loaded state: 2
Lever 'lever3gates' loaded state: 0
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: No collider found for 'general_portal_closed.ent'
WARNING: No collider found for 'general_portal_open.ent'
WARNING: Couldn't find sound entity 'Laser8'
WARNING: Can't find sound 'roll_metal_barrel' (may also be due too many sounds playing).
ERROR: Couldn't play sound 'roll_metal_barrel' for sound entity Roll
WARNING: Can't find sound 'roll_metal_barrel' (may also be due too many sounds playing).
ERROR: Couldn't play sound 'roll_metal_barrel' for sound entity Roll
WARNING: Couldn't find sound entity 'Laser0'
WARNING: Couldn't find sound entity 'Laser7'
WARNING: Couldn't find sound entity 'Laser3'
WARNING: Couldn't find sound entity 'Laser9'
--------------------------------------------------------

Statistics
--------------------------------------------------------
Medium framerate: 779.136600
--------------------------------------------------------

User Exit
--------------------------------------------------------
  Saving to config
  Saving keys
  Saving to config
  Saving keys
Reset maphandler
Exit Player
Exit Button Handler
Exit Map Handler
Exit Game Message Handler
Exit Radio Handler
Exit Inventory
Exit Fade Handler
Exit Save Handler
Exit Trigger Handler
Exit Attack Handler
Exit Notebook
Exit Numerical panel
Exit Intro story
Exit Death menu
Exit Graphics helper
Exit Main menu
Exit Player hands
Exit Music handler
Exit Map Load Text
Exit PreMenu
Exit Credits
Exit Ending
Exit Demo end text
Exit Gui Handler
Exit Sound Environment Handler
Exit Shooter
Saving config
Exit Effect Handler
Exit Game
--------------------------------------------------------

Exiting Gui Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Scene Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Input Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Sound Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Graphics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting Resources Module
--------------------------------------------------------
Done with tilesets
Done with fonts
Done with scripts
Done with particles
Done with sounds
Done with meshes
Done with materials
Done with Gpu programs
Done with images
Destroyed all textures
Done with sound entities
Done with animations
All resources deleted
--------------------------------------------------------

Exiting Physics Module
--------------------------------------------------------
--------------------------------------------------------

Exiting System Module
--------------------------------------------------------
--------------------------------------------------------

Deleting game setup provided by user
- Deleting lowlevel stuff.
  Physics
  Sound
  Input
  Resources
  System
  Graphics
  Haptic
HPL Exit was successful!
Saving last config
Deleting ATI shader to 0
Deleting ATI shader to 0
Deleting ATI shader to 0
Deleting ATI shader to 0

As You can see there are some errors.
(This post was last modified: 01-08-2010, 10:07 PM by Rex.)
01-08-2010, 09:22 PM
Find
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#6
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Is there anyone who can analyze the log I've posted above? I still haven't resolved the issue on my own,
01-14-2010, 06:49 PM
Find
eoverton Offline
Junior Member

Posts: 2
Threads: 1
Joined: Jun 2009
Reputation: 0
#7
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

It sounds like the same problem I was having in this thread:

http://frictionalgames.com/forum/showthr...p?tid=2971

Basically, a physics glitch that sucks up your CPU power. You can either start again from an earlier level (provided you've got a save file from the previous level) or download the save file posted in that thread. Hope that helps!
01-17-2010, 12:03 AM
Find
raffael Offline
Junior Member

Posts: 6
Threads: 1
Joined: Jan 2010
Reputation: 0
#8
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Quote:Basically, a physics glitch that sucks up your CPU power. You can either start again from an earlier level (provided you've got a save file from the previous level) or download the save file posted in that thread. Hope that helps!

Yes! That's it. I've reloaded the savegame from previous level, finished it again and entered level 6. Everything is fine now. Thank You very much for this information Smile I've finished Requiem without any other issues so I guess it's only level 6 problem. Anyway, the proble is resolved. Thank You again.
(This post was last modified: 01-19-2010, 02:43 PM by Rex.)
01-19-2010, 02:41 PM
Find
nympholept Offline
Junior Member

Posts: 2
Threads: 0
Joined: Sep 2009
Reputation: 0
#9
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

(01-17-2010, 12:03 AM)eoverton Wrote: Basically, a physics glitch that sucks up your CPU power.
Thanks for the explanation!
I had searched the forum for info last year, but eventually just abandoned playing requiem because other people were having the same problem as me and no-one was getting any answers.
I had thought it was just because I had a Radeon, since it was mainly Radeon users who had the problem.

Hopefully now that the cause is known, Frictional can patch it.
05-12-2010, 07:45 AM
Find
nympholept Offline
Junior Member

Posts: 2
Threads: 0
Joined: Sep 2009
Reputation: 0
#10
Solved: 5 Years, 10 Months, 2 Weeks ago RE: Terribly low FPS in Requiem Level 6 @ Radeon HD4670

Any updates on this, or are we stuck with the glitch?
10-10-2010, 07:30 PM
Find




Users browsing this thread: 1 Guest(s)