The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 906 - File: showthread.php PHP 7.2.24-0ubuntu0.18.04.17 (Linux)
File Line Function
/showthread.php 906 errorHandler->error

Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to unpack installer (or corrupt installer)?
nitro322 Offline
Junior Member

Posts: 4
Threads: 1
Joined: Jun 2012
Reputation: 0
Solved: 9 Years, 6 Months, 1 Week ago How to unpack installer (or corrupt installer)?

I'm trying to package Amnesia: AMfP for my distribution (gentoo), but I'm having trouble non-interactively unpacking the files from the installer. This appears to be a makeself 2.1.5 installer, which supports (or is supposed to support) the --tar argument to unpack the files. However, when attempting to do so, I get the following:

$ sh ~/download/Amnesia\ -\ A\ Machine\ for\ Pigs/ --tar xfv
basename: extra operand ‘A’
Try 'basename --help' for more information.

The basename error occurs inside the script - not sure why, but it may be related to this problem. Although some files were extracted, this doesn't include the game data. In fact, it's only about 1 MB total worth of extracted files.

As an alternative, I tried using the --target option to specify where the extract files should be placed:

$ sh ~/download/Amnesia\ -\ A\ Machine\ for\ Pigs/ --target ~/temp/AmnesiaAMFP-1.0.0
basename: extra operand ‘A’
Try 'basename --help' for more information.
Creating directory ~/temp/AmnesiaAMFP-1.0.0
Verifying archive integrity... All good.
Uncompressing Mojo Setup..............
Collecting info for this system...
Operating system: linux
CPU Arch: x86_64
trying mojosetup in bin/linux/x86_64

But, it again only extracts a small number of files (same as before, with the addition of "frontendstarted"). It tries to kick off the installers, but fails with an error message that states:

Failed to start. Is your download incomplete or corrupt?

So, I checked to see if maybe that was the case, but the MD5 checksum for my downloaded installer exactly matches the MD5 checksum provided by Humble Bundle (I purchased this through tthe Humble Store):


I can, however, interactively install and play the game just fine (at least through the first level).

So, I'm stuck right now. Is there a bug in the installer that breaks this functionality for some reason? Is the version provided to the Humble store somehow corrupt? Is there some other method I should be using instead to do this?

Would appreciate any feedback. Thanks.
(This post was last modified: 09-16-2013, 01:18 AM by nitro322.)
09-16-2013, 01:05 AM

Messages In This Thread
How to unpack installer (or corrupt installer)? - by nitro322 - 09-16-2013, 01:05 AM

Users browsing this thread: 1 Guest(s)