Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Slackware 12.2 - After Intro Games Will Not Work (yet)
dennola4 Offline
Junior Member

Posts: 5
Threads: 1
Joined: Jul 2009
Reputation: 0
#3
Solved: 6 Years, 2 Months, 2 Weeks ago RE: Slackware 12.2 - After Intro Games Will Not Work (yet)

I am on a laptop -- Dell Inspiron 6000 -- and the video card is : 128MB ATI Mobility Radeon X300Video Card

The output of glxinfo (you asked for it) is:

Dennis@slackware:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_import_context, GLX_EXT_texture_from_pixmap,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
    GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGI_swap_control, GLX_SGI_video_sync, GLX_SGIS_multisample,
    GLX_SGIX_fbconfig, GLX_SGIX_visual_select_group
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 915GM 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.3
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_fragment_program, GL_ARB_imaging,
    GL_ARB_multisample, GL_ARB_multitexture, GL_ARB_point_parameters,
    GL_ARB_shadow, GL_ARB_texture_border_clamp, GL_ARB_texture_compression,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_texture_rectangle, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color,
    GL_EXT_blend_equation_separate, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_cull_vertex, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_histogram, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
    GL_EXT_secondary_color, GL_EXT_separate_specular_color,
    GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_texture_rectangle,
    GL_EXT_vertex_array, GL_3DFX_texture_compression_FXT1,
    GL_APPLE_client_storage, GL_APPLE_packed_pixels,
    GL_ATI_blend_equation_separate, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_INGR_blend_func_separate,
    GL_MESA_pack_invert, GL_MESA_ycbcr_texture, GL_MESA_window_pos,
    GL_NV_blend_square, GL_NV_light_max_exponent, GL_NV_texture_rectangle,
    GL_NV_texgen_reflection, GL_NV_vertex_program, GL_NV_vertex_program1_1,
    GL_OES_read_format, GL_SGI_color_matrix, GL_SGI_color_table,
    GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
    GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SGIX_depth_texture,
    GL_SUN_multi_draw_arrays

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x27 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x28 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x29 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x2b 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2c 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x2d 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2e 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x2f 24 dc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x30 24 dc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x31 24 dc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x32 24 dc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x65 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
Dennis@slackware:~$

The output for the hpl.log is:

Check serial!
-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
  Max texture image units: 8
  Max texture coord units: 8
  Two sided stencil: 0
  Vertex Buffer Object: 1
  Anisotropic filtering: 1
  Max Anisotropic degree: 2
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 141802944
  ATI Fragment Shader: 0
Creating graphic systems
  Creating Renderer2D
  Renderer2D created
  Creating Renderer3D
   Load Renderer3D gpu programs:
    Extrude
CG: 'ShadowExtrude_vp.cg' using profile: 'arbvp1'
CG: 'ShadowExtrude_fp.cg' using profile: 'arbfp1'
    Diffuse Vertex
CG: 'Diffuse_Color_vp.cg' using profile: 'arbvp1'
    Diffuse Fragment
CG: 'Diffuse_Color_fp.cg' using profile: 'arbfp1'
    Fog
CG: 'Fog_Solid_vp.cg' using profile: 'arbvp1'
CG: 'Fog_Solid_fp.cg' using profile: 'arbfp1'
   Creating fog textures: Solid Additive Alpha
CG: 'refract_vp.cg' using profile: 'arbvp1'
CG: 'refract_fp.cg' using profile: 'arbfp1'
CG: 'refract_special_fp.cg' using profile: 'arbfp1'
   init sky box
  Renderer3D created
Creating screen buffers size 800.000000 : 600.000000
Creating programs
CG: 'PostEffect_Blur_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Blur_Rect_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Blur_2D_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Bloom_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Bloom_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_Motion_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_Motion_fp.cg' using profile: 'arbfp1'
CG ERROR : The compile returned an error.
-----------------------------------
core/programs/PostEffect_Motion_fp.cg(32) : error C5013: profile does not support "for" statements and "for" could not be unrolled.
-----------------------------------
CG: Error loading: 'core/programs/PostEffect_Motion_fp.cg'!
ERROR: Couldn't create program 'PostEffect_Motion_fp.cg'
Dynamic loops in motion blur fp not supported, loading static instead.
CG: 'PostEffect_Motion_staticloop_fp.cg' using profile: 'arbfp1'
CG: 'PostEffect_DoF_vp.cg' using profile: 'arbvp1'
CG: 'PostEffect_DoF_fp.cg' using profile: 'arbfp1'
  RendererPostEffects created
Adding engine materials
--------------------------------------------------------

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
  Trying to open audio device... Success!
  Device name: ALSA Software on default
  Number of mono sources: 32
--------------------------------------------------------

Initializing Game Module
--------------------------------------------------------
Adding engine updates
Initializing script functions
--------------------------------------------------------

User Initialization
--------------------------------------------------------
WARNING: Language entry 'EventKeyInNoPower' in category '01_10_small_shaft' already exists!
Initializing Penumbra: Overture Episode 1
  Version    $Rev: 2553 $
  Date    $Date: 2008-04-09 23:06:19 -0400 (Wed, 09 Apr 2008) $
Checking Supported Profiles
  Profile CG_PROFILE_VP20 is supported
  Profile CG_PROFILE_ARBVP1 is supported
  Profile CG_PROFILE_ARBFP1 is supported
Trying to load vertex program!
CG: 'Test' using profile: 'arbvp1'
Success!
CG: 'DiffuseSpec_Light_vp.cg' using profile: 'arbvp1'
CG: 'DiffuseSpec_Light_Spot_vp.cg' using profile: 'arbvp1'
CG: 'BumpSpec_Light_fp.cg' using profile: 'arbfp1'
CG: 'BumpSpec_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Ambient_Color_fp.cg' using profile: 'arbfp1'
--------------------------------------------------------

Game Running
--------------------------------------------------------
Loading collada for 'maps/level00_01_boat_cabin.dae' took: 400 ms
CG: 'Fog_Trans_vp.cg' using profile: 'arbvp1'
CG: 'Fog_Trans_Alpha_fp.cg' using profile: 'arbfp1'
CG: 'Diffuse_Light_vp.cg' using profile: 'arbvp1'
CG: 'Diffuse_Light_Spot_vp.cg' using profile: 'arbvp1'
CG: 'Diffuse_Light_fp.cg' using profile: 'arbfp1'
CG: 'Diffuse_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Bump_Light_fp.cg' using profile: 'arbfp1'
CG: 'Bump_Light_Spot_fp.cg' using profile: 'arbfp1'
CG: 'Fog_Trans_Mod_fp.cg' using profile: 'arbfp1'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
CG: 'BumpColorSpec_Light_fp.cg' using profile: 'arbfp1'
CG: 'BumpColorSpec_Light_Spot_fp.cg' using profile: 'arbfp1'
WARNING: Bone 'joint1' is not attached to skin!
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry  joint parten '' is missing! Might be connected to bone.
ERROR: Child body 'joint1' for joint 'sjoint2' in mesh 'boat_dynamicparaffin.dae' does not exist!
ERROR: Cannot find sub entity 'parrafinlight_joint1' in mesh 'boat_dynamicparaffin.dae'
Loading map 'level00_01_boat_cabin.dae' took: 7197 ms

So that's where we're at so far. I guess now is a good time to reiterate that the first time I tried to play, after the initial fresh install, I panicked and ripped the whole directory and all contents from the machine then reinstalled into /usr/local/games. When it didn't work I ripped THAT directory out, re-reinstalled to /home/Dennis and then realized my issue was -- at the very least -- the DRI not being turned on. It occurs to me that this was crude and not a proper Uninstall. This is just to help you fully understand what you are diagnosing here.

Thanks.
07-19-2009, 08:53 PM
Find


Messages In This Thread



Users browsing this thread: 1 Guest(s)