Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Full-Screen vs. Win. Desktop
madFive Offline
Junior Member

Posts: 27
Threads: 3
Joined: Sep 2007
Reputation: 0
#1
Solved: 8 Years, 3 Months, 2 Weeks ago Full-Screen vs. Win. Desktop

Sorry for starting another whole new thread for this relatively minor issue.

When I run the game, it never goes completely to full-screen, even tho FullScreen="true" in settings.cfg. At first I can still see the entire start bar at the bottom of the screen blocking the bottom row of subtitles, and about an 8-pixel row on the right side where I can see the desk-top at the edge. The start-bar is eventually mostly covered, tho I haven't figured out exactly when, then i get the ~8 pixels still at the bottom and right that show thru to the desk-top.

I'm running an XFX AGP GF 7950GT with the xfx94.24 driver (only driver i've found that works properly with this card and openGL) if that helps at all. I normally run dual-screens, one at 1600x1200 and one at 1280x1024. When this problem first showed up, I disabled the second display to see if that would help, but the problem persisted. I started out running the game at its default 1280x1024, and in an effort to get rid of the problem I tweaked the settings.cfg to get the screen-res to my native 1600x1200, which still didn't help.

Any ideas on how to get rid of that desktop border would be appreciated. -Thanks
09-28-2007, 04:20 AM
Find
madFive Offline
Junior Member

Posts: 27
Threads: 3
Joined: Sep 2007
Reputation: 0
#2
Solved: 8 Years, 3 Months, 2 Weeks ago RE: Full-Screen vs. Win. Desktop

Arg... figured out part of the problem - I’m also using a window-blinds skin. Seems that disabling the skin causes penumbra to work properly. As a temporary fix I’ve set a per-application rule in windowBlinds to disable the skin when the app is loaded, but it'd really be better if penumbra could just take better control of the desk-top and get on top of all that. This is of-course the first game I’ve seen that had this problem, so it doesn't seem like it'd be too hard to compensate for.

edit: lol... this is getting oddly complicated. Seems turning on the "disabled" skin causes a problem inverse to what i had before: the game extends about 20 pixels onto the dual monitor; which, tho it doesn't look bad, causes a significant drop in fps for some reason. So now it seems, i need to disable both my dual-monitors and windows skin in order to achieve proper screen-size and frame-rates... whew... like i said, i haven't seen anything like this before, so a fix soon would be awsesome - thanks...
09-28-2007, 04:37 AM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#3
Solved: 8 Years, 3 Months, 2 Weeks ago RE: Full-Screen vs. Win. Desktop

Never used window blinds, so not sure what it is. But I have dual monitors myself and have tried Penumbra many different setups with out any problems.

I am using a special library, SDL, (for the engine to be portable) to init the fullscreen so it is something I do not have full control over. I will check if there are any issues between windows blinds and this.

One suggestion would be turning off windows blinds alltogether and see what happens. The dual monitors should not be any problem.
09-28-2007, 07:08 AM
Find




Users browsing this thread: 1 Guest(s)