Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


PCI - Express ??
celik Offline
Junior Member

Posts: 2
Threads: 1
Joined: Feb 2008
Reputation: 0
#1
Solved: 8 Years, 2 Months, 3 Weeks ago PCI - Express ??

My computer is a good system which runs any recent game with max settings and resolution with great fps. Some examples include BIOSHOCK - The Rapture and CRYSIS. But Penumbra is unplayable !

3.2 Ghz P4 Genuine / 3GB Dual Ram
PCI-Express Chipset
Geforce 8500 GTS 512Mb
XP Professional Ed. SP2

My friend brought me this game, after finishing it. He says it works fine in his computer which is worse than my computer but in my system, framerate drops to lower than 1 fps during any action and sometimes at other times. Worst part is, it's getting worse: about 7-8 seconds/frame Tongue

Hell I don't even know how I even made it to here. The game is fun enough I guess.. but it's impossible to go on further.

I have the latest drivers for everything and updated the game with all possible patches (tried all the intermediary steps as well). I even ran it with NO other programs or residents running: Nothing.
(Which is useless, Because I know my system can run half a dozen games simultaneously)

And nope it doesn't work at all..

Funny part is the performance is exactly the same for ALL settings. I tried the absolute minimum settings for everything and the only difference was the game looked very bad as well.. So I decided to max out everything.

One question: Can this be because of the PCI-E chipset I have?
(This post was last modified: 02-21-2008, 06:18 PM by ottk3.)
02-21-2008, 06:11 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#2
Solved: 8 Years, 2 Months, 3 Weeks ago RE: PCI - Express ??

The game uses OpenGL which none of the games you listed do. Try uninstalling the drivers and then installing them again and see if that helps. Perhaps there is some OpenGL setting in the control panel that messes things up.
02-21-2008, 06:20 PM
Find
celik Offline
Junior Member

Posts: 2
Threads: 1
Joined: Feb 2008
Reputation: 0
#3
Solved: 8 Years, 2 Months, 3 Weeks ago RE: PCI - Express ??

There are no OpenGL settings in the Nvidia panel.
(it had in previous versions from 2-3 years ago)

But I did a benchmark on my OpenGL and everything seems to be fine..
Framerates were over 1000 FPS in most tests. Too fast maybe? Tongue

My openGL 2.1 drivers came with my Nvidia bundle. honestly I don't know how to uninstall them. Smile

I'll try to find some OpenGL games to compare performance.
02-21-2008, 07:25 PM
Find
EncryptorX Offline
Junior Member

Posts: 1
Threads: 0
Joined: Jun 2006
Reputation: 0
#4
Solved: 8 Years, 2 Months, 3 Weeks ago RE: PCI - Express ??

what driver version u have? i know that 169.21 work ,.. all new up are having issues with opengl games.
03-02-2008, 04:33 AM
Find




Users browsing this thread: 1 Guest(s)