Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Steam Linux Beta?
felixmole Offline
Senior Member

Posts: 482
Threads: 7
Joined: Dec 2012
Reputation: 10
#11
Solved: 8 Years, 4 Months, 3 Weeks ago RE: Steam Linux Beta?

By the way (now that I'm back on Linux), here's my hpl.log (there's a segfault then):

-------- THE HPL ENGINE LOG ------------

Creating Engine Modules
--------------------------------------------------------
Creating graphics module
Creating system module
Creating resource module
Creating input module
Creating sound module
Creating physics module
Creating ai module
Creating gui module
Creating haptic module
Creating scene module
--------------------------------------------------------

Initializing Resources Module
--------------------------------------------------------
Creating resource managers
Misc Creation
--------------------------------------------------------

Initializing Graphics Module
--------------------------------------------------------
Init low level graphics
Setting video mode: 800 x 600 - 32 bpp
Init Glee...OK
Setting up OpenGL
  Max texture image units: 32
  Max texture coord units: 16
  Two sided stencil: 0
  Vertex Buffer Object: 0
  Anisotropic filtering: 0
  Multisampling: 1
  Vertex Program: 1
  Fragment Program: 1
  NV Register Combiners: 0
  NV Register Combiners Stages: 145409016
  ATI Fragment Shader: 0
Creating graphic systems
  Creating Renderer2D
ERROR: Couldn't texture 'PointLight2D.bmp'
FATAL ERROR: Couldn't load PointLight2D

It also appears to be failing to retrieve libXcursor.so.1 which is supposed to be in /home/felix/.local/share/Steam/SteamApps/common/Penumbra Overture/lib/

Any ideas?
03-02-2013, 10:06 AM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#12
Solved: 8 Years, 4 Months, 3 Weeks ago RE: Steam Linux Beta?

I think that in general you need to install a 32-bit lib package to be able to run in a 64-bit system. If I recall correctly the package is called ia32-libs or something similar, not sure if this is still the case.
03-04-2013, 08:58 AM
Website Find
felixmole Offline
Senior Member

Posts: 482
Threads: 7
Joined: Dec 2012
Reputation: 10
#13
Solved: 8 Years, 4 Months, 3 Weeks ago RE: Steam Linux Beta?

Yup, but it seems this package doesn't include 4-5 libraries that you have to download one by one (I'm seeing libCg.so right now). Without this maneuver it appears the game won't run on Ubuntu x64.
03-10-2013, 09:51 AM
Find




Users browsing this thread: 1 Guest(s)