Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
naguz Offline
Junior Member

Posts: 1
Threads: 1
Joined: Feb 2013
Reputation: 0
#1
Solved: 8 Years, 3 Months, 2 Weeks ago Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so

Hi,

I suspect many of the users who try to run any of the penumbra games on a recent distro after installing the Penumbra Collection on will have this problem.
ALSA lib dlmisc.c:236:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
Now, first of all, you must have the 32bit version of alsa-plugin-pulseaudio installed. That would be yum install alsa-plugin-pulseaudio.i686 on Fedora.

But you'll still get the error. Even if the library IS there, and working fine with everything else.

The problem is in libvorbis which is bundled with the games. I don't know if it's hardcoded against an earlier version of the alsa-pulse lib, or if there is something else plain wrong with it (or with something else).

Anyway: In WhereYouInstalledTheCollection/PenumbraCollection/BlackPlague/lib simply move the libvorbis.so-files out of the directory and paste it somewhere else for safekeeping (like the parent folder). The same goes for the same files in PenumbraCollection/Overture/lib/ for Overture. I just moved both files, ie. the so and the symlink.

Note: So far, I have not noticed any missing sound. Still, it might pop up later. Thought it should be posted here for reference in any case, although I see similar threads with other files moved as solutions. Oh, and if you decide to fix his bit, you might also concider to fix the fact that nixstaller hangs in the same place all the time, at least for me on Fedora 17, in step 3/3 when copying license files or similar. I can give you more details if you, are willing to spend time to fix small bugs like this for this ol' pack of games.

The Steam-version of Overture works brilliantly (also without the *annoying* SDL-grabbing-all-input-part), but sadly I don't have the other games on Steam.
02-03-2013, 01:42 AM
Find




Users browsing this thread: 1 Guest(s)