Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


No keyboard 1234567890 keys and mouse wheel buttons
siegfriedd Offline
Junior Member

Posts: 2
Threads: 1
Joined: Apr 2013
Reputation: 0
#1
Solved: 8 Years, 4 Months, 3 Weeks ago No keyboard 1234567890 keys and mouse wheel buttons

Hi,

I'm running debian sid, i managed to run Overture deleting some libs in the lib folder and putting my own.

The game launches fine and runs well, except the fact the mouse wheel does not work (outside the game it works), and the 1234567890 keys do not work (so i guess it's pretty hard to play this game unless i want to go in the inventory everytime i need to switch weapons).
It's a pity we cannot set these keys in the options..

I have an azerty (french) keyboard, so it might be the cause (though caps lock does not help)... But for the mouse......

I'm running the latest available version of Overture from Humble Indie.

Thanks for the help.
(This post was last modified: 04-08-2013, 01:13 AM by siegfriedd.)
04-08-2013, 12:46 AM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#2
Solved: 8 Years, 4 Months, 3 Weeks ago RE: No keyboard 1234567890 keys and mouse wheel buttons

The mouse is interesting.. My guess would be some X configuration issue. Penumbra basically assumes mouse button 4 and 5 are the wheel.

As for the number keys, that is a known issue with SDL 1.2 based games and many non-US keyboard layouts. And unfortunately there isn't any easy fix for it other than changing your input layout when running Penumbra. The plan is to switch to SDL 2.0 for future games which does not have this annoying limitation.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
04-08-2013, 01:53 AM
Website Find
siegfriedd Offline
Junior Member

Posts: 2
Threads: 1
Joined: Apr 2013
Reputation: 0
#3
Solved: 8 Years, 4 Months, 3 Weeks ago RE: No keyboard 1234567890 keys and mouse wheel buttons

Thanks for the quick response Urkle, much appreciated Smile

Indeed i made the following script for me to run penumbra:

#!/bin/bash
sudo /etc/init.d/bumblebeed start
setxkbmap -layout us
optirun ./penumbra
setxkbmap -layout fr


i have an optimus card, so for those that don't have one, just use:

#!/bin/bash
setxkbmap -layout us
./penumbra
setxkbmap -layout fr

With your current layout instead of "fr".
And the buttons work fine for me (need to redefine the buttons in the options).

I wonder if it's not optirun/bumblebeed that causes the mouse issue, i tried to add my mouse in the xorg config of bumblebee but it's the same, still no wheel.

At least the keyboard now works, so it's playable, thanks a lot! Smile
04-09-2013, 12:12 AM
Find




Users browsing this thread: 1 Guest(s)