Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


graphic problems - fog and light on textures
stpohle Offline
Junior Member

Posts: 7
Threads: 2
Joined: Jun 2008
Reputation: 0
#1
Solved: 5 Years, 7 Months, 2 Weeks ago graphic problems - fog and light on textures

Hi all,

The game itself runs fine here but i have some graphical glitches.

First i have a broken version of fog i think. Look at the screenshot below, there you see outside the window that the white fog has some big white qubes around it. In the Episode 1 i've never seen something like that. This, i experienced already during the demo version (Black Plaque) with the freezer pipe, but i thought it's just some small bug.
[attachment=542]

The second wierd thing is shown in the next screenshot. On the floor it looks like some kind of light but i think it's wrong there..
[attachment=541]

About the system i use:

penumbrablackplague version? 2567

Debian lenny/sid, X.Org X Server 1.4.0.90
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 Ti 4200 with AGP8X/AGP/SSE2
OpenGL version string: 1.5.8 NVIDIA 96.43.05
OpenGL extensions:

If you need more informations let me know and hopefully there will be a patch or something to fix this problems.

bye bye,
Steffen Pohle
06-18-2008, 09:35 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#2
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

1st problem: Try updating your drivers, else just turn of refraction in the advanced graphics settings.

2nd problem: Not a problem. Everything is as it should.
06-18-2008, 09:41 PM
Find
stpohle Offline
Junior Member

Posts: 7
Threads: 2
Joined: Jun 2008
Reputation: 0
#3
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

Thomas Wrote:1st problem: Try updating your drivers, else just turn of refraction in the advanced graphics settings.

2nd problem: Not a problem. Everything is as it should.

Hi there,

I tried to disable refraction but it haven't changed anything also installing the nevest driver haven't changed anything since it was the current one from the nvidia webpage. The problem is there also without windows. (Like in the demo the very cold steam, or what it was which you could turn of at the freezer or just cover it with something.. )

bye bye,
Steffen

[attachment=543]
this is a new screenshot.. maybe the small one wasn't good enought.
06-18-2008, 10:11 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#4
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

It looks exactly like the bug some other people have had and that had to do with refractions.

Did you uninstall the drivers and and rebooted before installing the new ones? This has helped in a lot of cases.
06-19-2008, 07:54 AM
Find
stpohle Offline
Junior Member

Posts: 7
Threads: 2
Joined: Jun 2008
Reputation: 0
#5
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

Thomas Wrote:It looks exactly like the bug some other people have had and that had to do with refractions.

Did you uninstall the drivers and and rebooted before installing the new ones? This has helped in a lot of cases.

Yes i did but hasn't changed a bit. I was looking also on my laptop to see if i have there the same problem and i had. After i looked into the hpl.log file and i found this:
....
WARNING: Serialize class '' not found!
WARNING: Serialize class '' not found!
WARNING: Serialize class '' not found!
WARNING: Serialize class '' not found!
WARNING: Serialize class '' not found!
Loading collada for 'maps/level04_messhall.dae' took: 1677 ms
ERROR: Couldn't create material 'particle_rockpiece.mat'
ERROR: Couldn't create material 'particle_rockpiece.mat'
ERROR: Couldn't create material 'particle_metalpiece.mat'
ERROR: Couldn't create material 'particle_metalpiece.mat'
ERROR: Couldn't find particle system file 'particle_imp_generic_hard.ps'
WARNING: Parent 'group3' couldn't be found! Failed to attach 'artefact01_pointLight1' to 'artefact01'.Attaching directly to mesh.
ERROR: Couldn't find particle system file 'particle_imp_generic_hard.ps'
ERROR: Couldn't create SoundEntity 'unbreak_impact_metal_soft_furniture_med.snt'
WARNING: Couldn't preload sound 'unbreak_impact_metal_soft_furniture_med'
ERROR: Couldn't find particle system file 'particle_imp_generic_hard.ps'
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
WARNING: Geometry joint parten '' is missing! Might be connected to bone.
WARNING: Geometry for joint child '' is missing! Might be connected to bone.
......

Config of the laptop:
Also Debian / Lenny (testing)
OpenGL renderer string: GeForce Go 6600/PCI/SSE2
OpenGL version string: 2.1.2 NVIDIA 169.12

Maybe this helps now to find the problem..
bye bye,
Steffen
06-19-2008, 10:23 AM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#6
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

Might be some Linux related bug for lower end cards. Afraid I cannot give any more tips since I do not have Linux.
06-19-2008, 10:58 AM
Find
sybesis Offline
Junior Member

Posts: 30
Threads: 5
Joined: Apr 2007
Reputation: 0
#7
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

you could try to turn off every effect.
If the problem is resolved turn on some effect then test if the problem come back.

I believe your graphic card isn't the problem. May be the driver. My nvidia driver is at version 173. Who know they may corrected some bugs with alpha and or glsl. But i doubt that. Because this kind of bug seems critical. correcting a bug like that 3 year after the release of your card seems "bizarre".

While on the other hand. the probleme could be something like penumbra not able to find the file that does the alpha test on the particle. or your card handle GLSL or CG strangely.
06-22-2008, 06:17 AM
Find
stpohle Offline
Junior Member

Posts: 7
Threads: 2
Joined: Jun 2008
Reputation: 0
#8
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

sybesis Wrote:you could try to turn off every effect.
If the problem is resolved turn on some effect then test if the problem come back.

I already tried this but it haven't changed a bit. Also i tested it with restarting the game. Another thing is why i have the same problem also on the laptop which has a newer Nvidia card.

I'll test now the new gfx driver from nvidia which they released two nights ago.

Bye Bye,
Steffen
06-22-2008, 11:40 AM
Find
sybesis Offline
Junior Member

Posts: 30
Threads: 5
Joined: Apr 2007
Reputation: 0
#9
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

stpohle Wrote:
sybesis Wrote:you could try to turn off every effect.
If the problem is resolved turn on some effect then test if the problem come back.

I already tried this but it haven't changed a bit. Also i tested it with restarting the game. Another thing is why i have the same problem also on the laptop which has a newer Nvidia card.

I'll test now the new gfx driver from nvidia which they released two nights ago.

Bye Bye,
Steffen

you may have a corrupt archive with missing files?
06-23-2008, 12:44 AM
Find
cloud Offline
Junior Member

Posts: 7
Threads: 0
Joined: Jul 2008
Reputation: 0
#10
Solved: 5 Years, 7 Months, 2 Weeks ago RE: graphic problems - fog and light on textures

Id agree its likely the OS is using either a corrupt or outdated file.

Have you played any other 3D game on your linux system such as ETQW?
07-17-2008, 09:29 PM
Find




Users browsing this thread: 1 Guest(s)