Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
still crashing
darthvulture Offline
Member

Posts: 53
Threads: 2
Joined: Apr 2007
Reputation: 0
#31
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

cant find that "integrated" driver, the only option in my device manager in that dislay driver option is ati radeon HD5800 series, there is no other option any ideas what to do?
trying that hotfix for ati cards right now, hope it works!
cant find that "integrated" driver, the only option in my device manager in that dislay driver option is ati radeon HD5800 series, there is no other option any ideas what to do?
trying that hotfix for ati cards right now, hope it works!

After Darkness, Comes Light.
(This post was last modified: 09-09-2010, 04:55 PM by darthvulture.)
09-09-2010, 04:55 PM
Find
Steezy Offline
Junior Member

Posts: 10
Threads: 1
Joined: Sep 2010
Reputation: 0
#32
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

(09-09-2010, 04:34 PM)Thomas Wrote: Cannot turn it off on mainboard?
Usually there is a switch or something on these things. I know that was true for an integrated soundcard I had.

just checked my mainboard and i couldn't find a switch. isn't there any way to force the game to use the nvidia chip? this whole on board graphis thing sucks. i finally want to play...
09-09-2010, 05:02 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#33
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

the SDL version (base lib we use) I use does not have any support for selecting card.

Perhaps mail some support and ask? I am not too into this kinda stuff Im afraid.
09-09-2010, 05:58 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#34
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

Hurs:
GLSL is hardware
09-09-2010, 05:59 PM
Find
Hurs Offline
Junior Member

Posts: 10
Threads: 1
Joined: Sep 2010
Reputation: 0
#35
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

ah ok then, time for a new computer XD
09-09-2010, 06:13 PM
Find
ThirdProphecy Offline
Junior Member

Posts: 6
Threads: 0
Joined: Sep 2010
Reputation: 0
#36
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

(09-08-2010, 08:38 PM)ThirdProphecy Wrote: my crash on startup doesnt give an error, just says "Amnesia.exe has stopped working..." and searches for a solution for a while then forces it to close. Nothing ever comes up though after clicking launch. I've tried all amounts of settings. I've also followed the reinstalling of video drivers method mentioned in other threads. Meaning:

I uninstalled my video drivers, restarted, it installed its drivers automatically, and i manually installed the NVidia drivers from the website, then rebooted. Still gets "amnesia.exe has stopped working" error. I've looked for an error log in documents>amnesia but all thats there is main>cfg file. I've also tried deleting that.

I have vista 64bit with geforce 9800GT graphics card. My rig should own this game Smile Any help would be much appreciated

I feel like nobody reads my posts. First asked for an error log, which as stated above I do not have, then linked to the troubleshooting thread which I've mentioned that I've DONE that troubleshooting. A LONG time ago, and I stated it. Also stated theres no error log, so keep that in mind too. My error is amnesia.exe has stopped working. i've done the basic troubleshooting on that thread.

ps, I've done the troubleshooting in that thread. it has NOT worked.

Big Grin

If you haven't done the troubleshooting on that thread, please don't post in this thread, you're behind! Tongue
I'f fixed it, and I'm going to give instructions here in case anyone else has the same issue:

I decided to see if anything running was crashing the program, so I disabled all of my startup programs and services through msconfig, and then rebooted. The game still crashed, and no icons were in the system tray (next to the clock and sound) regarding my antivirus utilities (microsoft security essentials, threatfire, and avast). I figured that meant they werent running, but upon closer inspection, the services still were. I disabled them one at a time to figure out if any of them were causing it, and it was Threatfire.

If you have a crash at the startup and have threatfire/vista/64bit (I'm not sure what all the conditions are, but threatfire mainly) You need to disable it from the services.msc.

Click start > Type in the startsearch "services.msc" and then press enter.

Find Threatfire, select it and click Stop in the upper left corner. (see screenshots)

After threatfire was turned off, amnesia started right up! Thanks for the help and I hope this helps others with the same crash!

p.s. It's a good idea to disabled ANY active antimalware programs on the computer if you're getting the same crash I did, this means AVG, Panda, Fsecure, Threatfire, Avast, Microsoft Security Essentials, Norton, Mcafee, etc. If you have to, disable them through services.msc as well, and remember you can always turn them back on if this doesnt fix it.


Attached Files
.jpg   servicessearch.jpg (Size: 29.75 KB / Downloads: 163)
.jpg   stopservice.jpg (Size: 100.44 KB / Downloads: 213)
(This post was last modified: 09-09-2010, 07:00 PM by ThirdProphecy.)
09-09-2010, 06:16 PM
Find
Thomas Offline
Frictional Games

Posts: 2,634
Threads: 184
Joined: Apr 2006
Reputation: 68
#37
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

ThirdProphecy:

Sorry if I missed any of your posts, there has just been so much lately.

Glad you solved it, adding to guide!
09-09-2010, 08:36 PM
Find
darthvulture Offline
Member

Posts: 53
Threads: 2
Joined: Apr 2007
Reputation: 0
#38
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

that ati hotfix clearly didnt work(bluescreened my pc) and there is no integrated driver option in device manager nor in the bios, the driver is fully updated and i posted my hpl log earlier and it seems like its that integrated driver that does it(would explain why worms is laggy) but how can i remove that? Sad

After Darkness, Comes Light.
09-10-2010, 12:01 AM
Find
Goldenlefty Offline
Junior Member

Posts: 10
Threads: 1
Joined: Sep 2010
Reputation: 0
#39
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

My problem is fixed Smile

I stopped trying to fix my video GeForce driver

My problem was Enhanced Display Driver Helper (ASUS Other Device)

I change for driver 1.39 and now i dont see that error anymore i hope it will help some people.

Now i am going to play
09-10-2010, 01:21 PM
Find
Marked One Offline
Junior Member

Posts: 3
Threads: 0
Joined: Sep 2010
Reputation: 0
#40
Solved: 5 Years, 9 Months, 1 Week ago RE: still crashing

(09-10-2010, 01:21 PM)Goldenlefty Wrote: My problem is fixed Smile

I stopped trying to fix my video GeForce driver

My problem was Enhanced Display Driver Helper (ASUS Other Device)

I change for driver 1.39 and now i dont see that error anymore i hope it will help some people.

Now i am going to play

If this isn't the solution, then I don't know what to do. I tried everything!

Downloading, updating and testing it now Sleepy
09-10-2010, 01:31 PM
Find




Users browsing this thread: 1 Guest(s)