Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
V-Sync is not stopping screen tearing
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#11
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

This is due to the adpative vsync, which turns of vsync when the performance is taking a hit. We have added an option to disable the adaptive vsync in the test exe and will be part of the hotfix (for the usb crash problem) coming out as soon as possible.

//while waiting, forcing the vsync using the control panel for the graphics card is the solution.
(This post was last modified: 09-10-2013, 06:14 PM by jens.)
09-10-2013, 06:12 PM
Website Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#12
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

Alright, great. I'll wait for the patch because the tearing is out of the roof for me apparently.

It's still strange though that the blue haze for me appeared when changing Adaptive vSync. Maybe the patch will fix that as well.
(This post was last modified: 09-10-2013, 06:18 PM by plutomaniac.)
09-10-2013, 06:16 PM
Find
CalinTM Offline
Junior Member

Posts: 41
Threads: 6
Joined: Sep 2013
Reputation: 0
#13
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

ETA for patch ?
09-10-2013, 06:52 PM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#14
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

Possibly within the hour on Steam. Currently uploading the files for other stores, but I think most of them will not be able to do their updates until tomorrow.
09-10-2013, 07:02 PM
Website Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#15
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

That fast? That's what I love about steam! Smile
(This post was last modified: 09-10-2013, 07:04 PM by plutomaniac.)
09-10-2013, 07:03 PM
Find
footwo Offline
Junior Member

Posts: 1
Threads: 0
Joined: Sep 2013
Reputation: 0
#16
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

OK so I've tried turning off the v sync in game and forcing it on the nvidia control panel but I'm still getting the tearing. I'm using a GTX 580, but on the nvidia control panel I don't see anything that lets me choose application specific behaviour.

The best I can find is this:

http://i.imgur.com/e20KaOn.png

Where I've set the refresh rate to 60 and told it to override the scaling mode, but the scaling mode isn't the refresh rate so I guess it's not overriding that.

Is there something else I have to do?
09-10-2013, 10:50 PM
Find
plutomaniac Offline
Super Moderator

Posts: 6,368
Threads: 45
Joined: May 2011
Reputation: 183
#17
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

It's under Manage 3D Settings menu.
09-10-2013, 10:59 PM
Find
ltr666 Offline
Junior Member

Posts: 7
Threads: 0
Joined: Sep 2013
Reputation: 0
#18
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

(09-10-2013, 10:50 PM)footwo Wrote: OK so I've tried turning off the v sync in game and forcing it on the nvidia control panel but I'm still getting the tearing. I'm using a GTX 580, but on the nvidia control panel I don't see anything that lets me choose application specific behaviour.

The best I can find is this:

http://i.imgur.com/e20KaOn.png

Where I've set the refresh rate to 60 and told it to override the scaling mode, but the scaling mode isn't the refresh rate so I guess it's not overriding that.

Is there something else I have to do?

The scaling has nothing to do with v-sync.

You need to go to:

Manage 3D settings
-> Program Settings
-> under "1. Select a program to customize:" click 'add' and browse to aamfp.exe, then scroll down to "Vertical Sync" and select "On". I have v-sync also turned on in game and it's working fine.

Note that if you can't get a stable 60fps on your rig you might still see some tearing or stuttering even with v-sync. If you get stutters try adaptive v-sync.
09-10-2013, 11:08 PM
Find
serbusfish Offline
Member

Posts: 211
Threads: 75
Joined: Aug 2012
Reputation: 0
#19
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

I turned adaptive V-sync off and it solved the problems for me. Just go into your Documents\Amnesia\Pig\ folder and edit the main_settings.cfg, find 'AdaptiveVsync' and set it to false, and make sure the other v-sync setting is true.

09-11-2013, 02:43 AM
Find
Babomancer Offline
Junior Member

Posts: 13
Threads: 2
Joined: Sep 2013
Reputation: 1
#20
Solved: 8 Years, 5 Months ago RE: V-Sync is not stopping screen tearing

OP here. As discussed before, forcing on vsync in my graphics card options fixed the issue, I'm not getting any tearing at all anymore. Further, with the new option to disable adaptive vsync, I was able to stop forcing vsync and it is working just as well.
09-11-2013, 08:18 AM
Find




Users browsing this thread: 1 Guest(s)