Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee

Installers won't Install
LilJoshu Offline
Junior Member

Posts: 8
Threads: 2
Joined: Jun 2009
Reputation: 0
Solved: 6 Years, 10 Months, 4 Weeks ago RE: Installers won't Install

Well, I got lucky and Penumbra Overture finally decided to stay with the right md5 after downloading yet again, as has Requiem...

However, I've tried an (I've lost count) number of times with Black Plague, it it never downloads with the right md5. In fact, I consistantly seem to be getting the same wrong md5. What's even weirder is the sh installer reports it having a different md5 than md5sum.

joshupetersen@Seikatsu:~/Desktop$ md5sum PenumbraBlackPlague-2567.sh[
b562ba5621c1367fcff325c353da1646  PenumbraBlackPlague-2567.sh
joshupetersen@Seikatsu:~/Desktop$ sh PenumbraBlackPlague-2567.sh
Verifying archive integrity...Error in MD5 checksums: 2f0caebc8519a9933dd6e17ede99986a is different from ebbdedfae81d8dd3e70b52589ced6258

...and I just realized that bolding and italisizing things for emphasis in code doesn't work... you can ignore those... or I'll go back and remove any I find.
06-25-2009, 06:08 AM
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
Solved: 6 Years, 10 Months, 4 Weeks ago RE: Installers won't Install

I have copied, md5sum'ed and moved around the files on my xubuntu 9.04. I can't reproduce the problems you are experiencing. At the moment I don't really have any suggestions, based on the random corruption it could be something on your system(ram, drive with errors), with the route of the download or perhaps the home network that causes it.

Have you tried downloading the game from the esellerate server as well? There is a link to the download in the email or on the purchase page you get access to from the email.
06-25-2009, 07:38 AM
Website Find
LilJoshu Offline
Junior Member

Posts: 8
Threads: 2
Joined: Jun 2009
Reputation: 0
Solved: 6 Years, 10 Months, 4 Weeks ago RE: Installers won't Install

Tried from the esellerate server, also failed...
However, on a hunch, just now tried something.
Downloaded on my Windows side (since I dual boot) and got md5's that were just fine. Burnt them to CD , and went back over to Ubuntu, and they installed just fine.

They still apparently have other issues, but ones that are covered by other threads on this forum. More than likely it implies (at least in my mind) that something, somewhere, was actually re-writing the files in the sh'ing process, maybe a bad update from a local server on sh, or something.

Anyway, it narrows the problem down as not being hardware (otherwise it would have had problems windows side too), and also not the files themselves (unless somehow running sh on them causes them to rewrite to themselves, as they couldn't do that with the DVD)...
All the OSes I tried were Debian based, it may have something to do with that (since I tried both Sabayon and Ubuntu, with various architecture layouts). Or the error could have been a weird and obscure combination of something the files, but something about debian format, mixed with my specific hardware (AMD64 dual core, Nvidia chipset, Nvidia Geforce 9500, 1G ram)

So, although never did figure exactly what the problem is, I guess it's a moot point for me now. Although what it means on the developer's end, I can only fathom.
Wait, you said it didn't have any problems on Xubuntu?....
I was using Ubuntu...
The main difference is yours is XFCE and mine is Gnome (which also Sabayon is).
Maybe it's an issue specifically with Debian Gnome distributions of the block of the ubuntu 9.04 version range? I dunno... just speculating... (since I got it to install, at this point my musing is largely in the hopes of shedding light to help future development and not self-interest, as I love it when developers make linux native versions of their games... one of the main reason I picked up Penumbra.)
06-25-2009, 07:56 AM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
Solved: 6 Years, 10 Months, 4 Weeks ago RE: Installers won't Install

That is VERY strange. I would suspect possibly a driver issue with the disk controller on the motherboard or bad memory.

Have you run memtest86 on the system? (you should be able to find a package for it in ubuntu to add to your grub menu).

Now are you copying with the GUI? or via the command line with cp?

What kernel revision are you using as well? and what chipset is the nvidia motherboard chipset?

Have you tried checking for firmware updates to your motherboard?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
06-25-2009, 05:17 PM
Website Find

Users browsing this thread: 1 Guest(s)