Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Extreme slowdowns
urandom Offline
Junior Member

Posts: 3
Threads: 1
Joined: Jul 2009
Reputation: 0
#1
Solved: 6 Years, 4 Months ago Extreme slowdowns

Hello,

I'm currently trying to play the Overture episode. I've noticed that at some precise moments, I get extreme slowdowns. The framerate drops to around 1 frame per couple of seconds. One such area is the very beginning of the 3rd level, where the character wakes up from the fall. Another one is when I first turn to face the swinging lamp in the boat during the 1st level.

These slowdowns seem to happen regardless of the settings I use. Currently I have set the game to 800x600 with a high shader level and motion blur / dof / bloom. I believe these slowdowns might be related to the game itself, rather than my laptop being slow, for several reasons. First, when I experience such a slowdown, everything is extremely slow. When I press [ESC], the menu appears after a couple of seconds, and the mouse response is not back to normal. If I change to another VT, like the first one, and then back again, the game speed is restored. The same effects that are in place during the swinging lamp scene that caused the slowdown are still in effect, yet the game now runs normal. Finally, on the outdoor level, there are quite a few motion blur / dof effects, but there is no noticeable slowdown.

My system specs are as follows:
Ubuntu Jaunty x86_64
Nvidia driver - 185.18.14

The video card is a GeForce 8400M GS.
RAM - 2 GB.
CPU - Intel Core 2 Duo T9500 @ 2.60

If more information is needed, please let me know.
07-17-2009, 07:49 PM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#2
Solved: 6 Years, 4 Months ago RE: Extreme slowdowns

If you turn off the dof effect completely does that remove the slow down?

Could you try and turn off the UI acceleration(I try hard but can't recall the name of it) in gnome before starting the game and see if that helps?
07-17-2009, 08:08 PM
Website Find
urandom Offline
Junior Member

Posts: 3
Threads: 1
Joined: Jul 2009
Reputation: 0
#3
Solved: 6 Years, 4 Months ago RE: Extreme slowdowns

(07-17-2009, 08:08 PM)jens Wrote: If you turn off the dof effect completely does that remove the slow down?

Could you try and turn off the UI acceleration(I try hard but can't recall the name of it) in gnome before starting the game and see if that helps?


I've tried turning off both motion blur and dof at one point. then passing the outside level so that I can see the cutscene when the character wakes up. Even without those effects, the slowdown is still there.

I'm not running gnome (or compiz), and there isn't any other app that is using opengl at the moment I start the game. However, I am running a rather simple compositor, which just redirects the windows. When I disabled it, I didn't notice the slowdowns. So unless they appear again while the compositor is disabled, it could be the reason for them. Not sure if there's anything you could do from the game to disallow the game's window to be redirected.

As a side note, the 'overture' script which is installed with the collection tries to start 'Overture/overture', but the actual script in that directory is called 'penumbra'. You might want to update that script for future customers Smile
07-17-2009, 09:34 PM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#4
Solved: 6 Years, 4 Months ago RE: Extreme slowdowns

I'm sure there is a way to detect compositing, as I've seen some apps do detection to "ensure" that it's enabled. but yes, compositing CAN slow things down. I sure hope the compositing subsystem gets cleaned up in X11 so that it runs as nicely as it does on Mac OS X (which is ALWAYS being composited via openGL)

As for the script... "oops" is all I can say.. I'll get that fixed though.. I also need to update the libCg in the distribution as the old one is causing issues with newer nvidia cards.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
07-17-2009, 09:57 PM
Website Find
darknigger Offline
Junior Member

Posts: 2
Threads: 0
Joined: Dec 2010
Reputation: 0
#5
Solved: 6 Years, 4 Months ago RE: Extreme slowdowns

Did anyone actually found a solution for this problem? I just purchased the penumbra collection and played through Overture with minor slowdowns just like described in this thread (switching to a login console and back to X solves the issue) but now that i'm playing Black Plague there's this place where every other room i go into causes this problem. Thanks in advance for any info / help on this.
12-09-2010, 12:16 AM
Find




Users browsing this thread: 1 Guest(s)