Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


Ubuntu 9.10 glitches
alazyworkaholic Offline
Junior Member

Posts: 3
Threads: 1
Joined: Nov 2009
Reputation: 0
#1
Solved: 6 Years, 11 Months, 1 Week ago Ubuntu 9.10 glitches

Computer:
780G Chipset
Realtek ALC889A integrated audio
4850e X2
ATI 4670 with manually installed catalyst 9.10 driver.
Ubuntu 9.10 Karmic Koala 32-bit.

Problems common to Overture, Black Plague & Requium. (bought separately - back when it was kinda expensive too!) I installed the 1.0.2253.sh patch over the original Overture install.

Sound is F'd. Usually works reasonably well for a few seconds to a minute, then becomes horribly garbled & choppy.

Graphics glitches:
I think I remember the hand being visible most/all of the time. Now it's only visible if it's directly in front of something that it can interact with. Or maybe I'm imagining things.
Didn't bother going far, but the snowy ground around the pit by the entrance at the beginning of overture is gone - transparent.
A giant parka, (looks like the one beside the cabin door at the very beginning) is on the floor & only visible from certain angles.
The boards behind the shelf in the 2nd room underground are invisible, but I still see splinters after swinging the hammer through what looks like air.
All of this on high level graphics. Low/Medium causes terrible corruption of all sorts.

Please let me know when a patch will be available, & if there are some workarounds that should reliably fix these issues for now.

edit: there's a thread: http://ubuntuforums.org/showthread.php?p...ost8252647
which suggests
./configure --disable-assembly in the SDL package
export SDL_AUDIODRIVER=alsa
but I really don't know how to do what's explained in this thread that was referred to: http://www.dxx-rebirth.com/smf/index.php?topic=591.15
If anyone has any suggestions, PLEASE let me know.
(This post was last modified: 11-06-2009, 06:47 PM by wandergirl.)
11-05-2009, 11:01 PM
Find
alazyworkaholic Offline
Junior Member

Posts: 3
Threads: 1
Joined: Nov 2009
Reputation: 0
#2
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

Any progress?
11-15-2009, 12:50 PM
Find
Lokal Offline
Junior Member

Posts: 1
Threads: 0
Joined: Nov 2009
Reputation: 0
#3
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

(11-15-2009, 12:50 PM)alazyworkaholic Wrote: Any progress?
I'd like to know the same thing. Just bought the collection a few days ago. I'm running Kubuntu 9.10 and those lags and poor sounds are kind of mood killers.
11-30-2009, 02:20 PM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#4
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

The patch is being worked on, but as these issues are specific to the new 9.10 release they might also be depending on fixes for 9.10 itself, it needs to mature a bit. The best tip I found for the sound issue was to do the following:

-Edit or create the file: "~/.pulse/client.conf" so it says "autospawn = no"
-Then kill pulseaudio by typing "killall pulseaudio" in the Terminal.
-Play Penumbra, hopefully with perfect audio!
-Type "pulseaudio -D" in the Terminal when done playing.

edit--
patch is out and this tip probably does not work any longer.

http://support.frictionalgames.com/entry/73/
(This post was last modified: 05-05-2010, 06:02 PM by jens.)
11-30-2009, 02:53 PM
Website Find
DeM Offline
Junior Member

Posts: 11
Threads: 1
Joined: Dec 2009
Reputation: 0
#5
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

(11-30-2009, 02:53 PM)jens Wrote: The patch is being worked on, but as these issues are specific to the new 9.10 release they might also be depending on fixes for 9.10 itself, it needs to mature a bit. The best tip I found for the sound issue was to do the following:

-Edit or create the file: "~/.pulse/client.conf" so it says "autospawn = no"
-Then kill pulseaudio by typing "killall pulseaudio" in the Terminal.
-Play Penumbra, hopefully with perfect audio!
-Type "pulseaudio -D" in the Terminal when done playing.

I confirm that it worked for me. Thanks!
12-17-2009, 12:27 AM
Find
Elwro Offline
Junior Member

Posts: 11
Threads: 1
Joined: May 2010
Reputation: 0
#6
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

(12-17-2009, 12:27 AM)DeM Wrote:
(11-30-2009, 02:53 PM)jens Wrote: The patch is being worked on, but as these issues are specific to the new 9.10 release they might also be depending on fixes for 9.10 itself, it needs to mature a bit. The best tip I found for the sound issue was to do the following:

-Edit or create the file: "~/.pulse/client.conf" so it says "autospawn = no"
-Then kill pulseaudio by typing "killall pulseaudio" in the Terminal.
-Play Penumbra, hopefully with perfect audio!
-Type "pulseaudio -D" in the Terminal when done playing.

I confirm that it worked for me. Thanks!
Unfortunately, this does not work for me (9.10, i386 32bit). When I do "killall pulseaudio", the game simply runs in complete silence. Any help?
05-05-2010, 05:54 PM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#7
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

Don't do that tip any longer!

In 9.10 the easiest fix is to remove the openal libs found in the lib folder in the penumbra folder. This makes the game use the openal libs installed with the system instead and that should work perfect with 9.10.

Another fix is to change the sound device in the games audio settings, the ALSA default can be problematic, but manually selecting a specific device makes it work as intended.

-edit
Ops, that was incorrect, I was thinking of 10.4 when replying. But I think the same applies to 9.10 as it has been updated a couple of times since the original post.
(This post was last modified: 05-05-2010, 06:01 PM by jens.)
05-05-2010, 06:00 PM
Website Find
Elwro Offline
Junior Member

Posts: 11
Threads: 1
Joined: May 2010
Reputation: 0
#8
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

(05-05-2010, 06:00 PM)jens Wrote: Don't do that tip any longer!

In 9.10 the easiest fix is to remove the openal libs found in the lib folder in the penumbra folder. This makes the game use the openal libs installed with the system instead and that should work perfect with 9.10.

Another fix is to change the sound device in the games audio settings, the ALSA default can be problematic, but manually selecting a specific device makes it work as intended.

-edit
Ops, that was incorrect, I was thinking of 10.4 when replying. But I think the same applies to 9.10 as it has been updated a couple of times since the original post.
Alright, thank you very much. Turns out I actually had to do BOTH of those things but now sound seems perfect. I hope it stays this way!

So, for the record, I removed (finding your FAQ page in the meantime) libogg, libopenal, libvorbis and libvorbisfile files (8 in total) from the lib directory AND chose the audio device "by hand" in the menu. Just the first step of this did not work for me.

Please tell me how I can run the game full screen on a 1440x900 monitor with nVidia official drivers. Full screen is a must for such games, and when I set the screen resolution to 1440x900 in the game it simply (upon startup) opens a window with this size on my desktop. I see no "full screen" option and Alt-Enter does not work.
05-05-2010, 06:10 PM
Find
jens Offline
Frictional Games

Posts: 4,093
Threads: 199
Joined: Apr 2006
Reputation: 202
#9
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

There should be a full screen option in there some where, or my memory is messed up. You can if nothing else open home dir/.frictionalgames/penumbra overtur/settings.cfg with gedit and find FullScreen="false" and change that to FullScreen="true".
05-05-2010, 06:18 PM
Website Find
Elwro Offline
Junior Member

Posts: 11
Threads: 1
Joined: May 2010
Reputation: 0
#10
Solved: 6 Years, 11 Months, 1 Week ago RE: Ubuntu 9.10 glitches

(05-05-2010, 06:18 PM)jens Wrote: There should be a full screen option in there some where, or my memory is messed up. You can if nothing else open home dir/.frictionalgames/penumbra overtur/settings.cfg with gedit and find FullScreen="false" and change that to FullScreen="true".
Thanks! That did the trick. I bought the game via the Humble Bundle, but you have a longer-term customer now Big Grin Thanks again!
05-05-2010, 06:25 PM
Find




Users browsing this thread: 1 Guest(s)