Facebook Twitter YouTube Frictional Games | Forum | Privacy Policy | Dev Blog | Dev Wiki | Support | Gametee


New Patch is HERE (August 30th!!) Feedback needed for final release.
DigitalPioneer
Unregistered

 
#11
Solved: 6 Years, 7 Months ago RE: New Patch on it's way!

Well, I'm going to appreciate that since I use Pulse myself. It makes bluetooth audio somewhat simpler. It's absolutely necessary to be able to change where audio is going while it's playing if you have bluetooth headphones.
08-01-2009, 01:19 AM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#12
Solved: 6 Years, 7 Months ago RE: New Patch on it's way!

ARGH!!!!!

Having serious computer issues.. My Linux box just lost a video card again. (3rd one). And I am fighting with the MacPro to get linux to actually boot (it did boot the live CD and install, just won't boot the installed copy.. ARGH)..

So unfortunately.. linux patch is stuck until I get this fixed or get another system. ARGH..

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
08-05-2009, 03:22 PM
Website Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#13
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

I've noticed 7 downloads so far.. Anyone have any feedback?

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-03-2009, 04:01 PM
Website Find
DigitalPioneer
Unregistered

 
#14
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

Ahh! It's here, I didn't see it! Big Grin

Feedback will arrive soon. Smile
No go. Same problem as before the patch: Game plays for about half a second, then video locks and audio keeps going (except since it's NOT using Pulseaudio, another app played sound and killed Overture's stream) without so much as a hiccup.

ATI HD 4850 w/ Catalyst 9.8, kernel 2.6.30.5
(This post was last modified: 09-03-2009, 04:20 PM by bighitman.)
09-03-2009, 04:14 PM
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#15
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

I'm sorry... where do I find the new patch? I do not see any announcement aside from the testing patch in the first post. (And the link there does not work anymore.)

I hope there will be a full new installer which I can archive? I like it to have the newest version in one installer-file without the need to update.

Thanks for the great support here!


Zak
09-05-2009, 11:46 AM
Find
DigitalPioneer
Unregistered

 
#16
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

AFAIK, the testing patch is all there is. Someone correct me if I'm wrong, because that means I need to install the real one.

As to the link being broken, I agree with you, but I can't help you. Sad
09-05-2009, 09:56 PM
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#17
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

Sorry about the broken link.. It's fixed now.. I had restarted that computer and forgot to startup azureus again. (I need to find a different tracker that I can daemonize on my server instead of proxying to my desktop)

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-06-2009, 01:30 AM
Website Find
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#18
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

(09-06-2009, 01:30 AM)Urkle Wrote: Sorry about the broken link.. It's fixed now.. I had restarted that computer and forgot to startup azureus again. (I need to find a different tracker that I can daemonize on my server instead of proxying to my desktop)

Hi Urkle,
I am just installing and testing...
Installer works fine so far. I notice it says "Choose the existing directory where Penumbra: Overture is installed". Install went fine with GUI...
I see the "PenumbraCollection/overture" script error has been fixed by placing the symlink "PenumbraCollection/Overture/overture". Ok.

There is a new language file "English.lang" in "PenumbraCollection/Overture/". Isn't this supposed to be in the "config"-directory?

All three games run fine (as they did before :-) ). I recognize the new Audio-Setting, but the option for hardware sound still does not work. I think we linux users have to abandon 5.1-surround sound, do we? :-( I do not use PulseAudio on my Debian unstable, so I cannot say anything about that. ALSA always fulfilled my needs.

Thanks for the work.
And PLEASE consider a native 64bit version for the next game.

Zak
09-06-2009, 11:15 AM
Find
Urkle Offline
FG - Associate

Posts: 1,172
Threads: 31
Joined: Jul 2006
Reputation: 21
#19
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

(09-06-2009, 11:15 AM)zak Wrote: Hi Urkle,
I am just installing and testing...
Installer works fine so far. I notice it says "Choose the existing directory where Penumbra: Overture is installed". Install went fine with GUI...
Guess I should have gone over it a bit more (it was a copy of the installer script from the Overture upgrade)

Quote:There is a new language file "English.lang" in "PenumbraCollection/Overture/". Isn't this supposed to be in the "config"-directory?
Oops.. Are you serious? Yup looks like I flubbed that one.. I've fixed it now. Thanks for pointing that one out.. I also fixed the labeling in the installer

Quote:All three games run fine (as they did before :-) ). I recognize the new Audio-Setting, but the option for hardware sound still does not work. I think we linux users have to abandon 5.1-surround sound, do we? :-( I do not use PulseAudio on my Debian unstable, so I cannot say anything about that. ALSA always fulfilled my needs.

I probably should have removed the "hardware" option in the menus as they don't do anything on linux/mac anyway. It was a Windows specific option that forces the "hardware" option for the Windows specific driver.

The OpenAL Soft driver I'm using *SHOULD* work assuming your Alsa drivers support it. (and yes pulse audio throws a big wrench and doesn't let you have hardware).

I'd suggest poking around the openal soft website for more info http://kcat.strangesoft.net/openal.html

I will try to spend some time working on and testing nice surround support for Unknown (I need to find my rear speakers for my SB Live card :-D ).

Quote:Thanks for the work.
And PLEASE consider a native 64bit version for the next game.

Assuming all the libraries work in 64bit (namely Newton Physics and Angelscript) I should be able to. I just need to get 64bit linux installed on my MacPro for testing when I get to that point.

Developing away on one of
Multiple Macs running 10.6, 10.7, 10.8, and 10.9.
Linux, 8-core AMD, 8GB RAM, Fedora 18, nVidia 450 1GB
09-06-2009, 06:34 PM
Website Find
zak Offline
Junior Member

Posts: 44
Threads: 4
Joined: Aug 2009
Reputation: 0
#20
Solved: 6 Years, 7 Months ago RE: New Patch is HERE (August 30th!!) Feedback needed for final release.

(09-06-2009, 06:34 PM)Urkle Wrote: The OpenAL Soft driver I'm using *SHOULD* work assuming your Alsa drivers support it. (and yes pulse audio throws a big wrench and doesn't let you have hardware).

I'd suggest poking around the openal soft website for more info http://kcat.strangesoft.net/openal.html

Well, I cannot explicitly select OpenAL there, but it seems to work fine (i.e. sound is working). In my hpl.log (nice filename by the way ;-) ) it says:

Initializing Sound Module
--------------------------------------------------------
Initializing OpenAL.
  Trying to open audio device... Success!
  Device name: ALSA Software on SB Audigy 2 ZS [SB0350] [ADC Capture/Standard PCM Playback] (hw:0,0)
  Number of mono sources: 32
  Vendor name: OpenAL Community
  Renderer: OpenAL Soft
  Output Devices:
    ALSA Software on default
    ALSA Software on SB Audigy 2 ZS [SB0350] [ADC Capture/Standard PCM Playback] (hw:0,0)
    ALSA Software on SB Audigy 2 ZS [SB0350] [Multichannel Capture/PT Playback] (hw:0,2)
    ALSA Software on SB Audigy 2 ZS [SB0350] [Multichannel Playback] (hw:0,3)
    ALSA Software on SB Audigy 2 ZS [SB0350] [p16v] (hw:0,4)
    OSS Software
    Wave File Writer
--------------------------------------------------------

If I should do some specific testing, just tell me what I can do.

Edit: Choosing the "Multichannel Playback"-device does not mean I have 5.1-surround-sound, does it?

Edit2: No :-(
"Multichannel Playback" and "p16v" leads to "AL lib: alsa.c:450: set access failed: Invalid argument" in the console.
"Multichannel Capture/PT Playback" results in "AL lib: alsa.c:388: Could not open playback device 'hw:0,2': No such device".
(OSS Software works.)

Zak
09-06-2009, 06:52 PM
Find




Users browsing this thread: 2 Guest(s)